snmpcollector not starting after install/upgrade - Connections could not be acquired from the underlying database!
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snmpcollector not starting after install/upgrade - Connections could not be acquired from the underlying database!

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Article ID: 9314

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

snmpcollector not starting after install/upgrade

Error in snmpcollector.log shows:

[SnmpCollectorMainExecution, snmpcollector] Exception thrown initializing database: Connections could not be acquired from the underlying database!
[SnmpCollectorMainExecution, snmpcollector] stderr: Exception in thread "SnmpCollectorMainExecution"
[SnmpCollectorMainExecution, snmpcollector] stderr: java.lang.NoClassDefFoundError: Could not initialize class com.nimsoft.probes.network.snmpcollector.database.PMF

Environment

DX UIM 20.4.x / 23.4 

Snmpcollector 4.04 and later

Cause

This issue appears to be caused by

- FQDN is not known
- internal database too busy to respond.
- corruption of internal database (snmpcollector.mv.db) file.

Resolution

On Linux, type env and look for HOSTNAME =
Add this hostname to /etc/hosts and restart snmpcollector.
---------------------------------------------------------------------------------------------

Note
:  We strongly encourage to use the latest snmpcollector probe version


The resolution is to perform the following steps:

1. Open snmpcollector in Raw Configure, add the below key to <setup> section and check if probe is started.

    MAX_BATCH = 3

2. If above does not help, search any recent backups of snmpcollector.mv.db taken. If you have, then deactivate the probe,
replace it with your backup, and start the probe. The DB backups can be found in the snmpcollector probe directory, as they are taken automatically.

3. If above does not help, deactivate the probe and move the following files out of the snmpcollector probe directory:

   - dbbackup.zip
   - all snmpcollector.mv.* files

Note that if you made any changes to the User defined property 1 fields of ifSpeeds, this info will be lost. Note also that by deleting the snmpcollector.mv.db file, you will lose anything that was manually added, e.g., profiles were not pulled in through the discovery_server as well as any/all "User defined property 1" values you added at the device and component level.

4. Activate the snmpcollector probe

5. Query the discovery_server for the devices to monitor. Note that you may have to delete and re-enter the discovery_server info in the Discovery Filter before you rediscover all of your profiles. If profiles were manually added before, they will have to be manually added again.

6. snmpcollector should be working as expected now and respond properly to a restart or cold start. Check the logs after completing the above steps.

7. If anything above does not help, try removing and redeploying SNMPcollector from scratch (remove the probe, then remove the probe's directory and deploy the fresh probe from the archive) 

Additional Information

Please also set the java heap min memory to 2048 at a minimum and max to 4096.

After a restart of the server the probe can be activated but sometimes ppm may throw a PPM-012 error.

The workaround for this error is normally,

1. DB_SERVER_MODE variable

- Open the probe snmpcollector in Raw Configure mode
- Under the <setup> section, add the key:

    DB_SERVER_MODE = true

- Deactivate and Activate the SNMPcollector probe

2. This issue is also sometimes seen when the PPM probe is not at the same version between the Primary Hub and the Secondary hub/snmpcollector.

Deploy the latest PPM probe on both the Primary and Secondary(snmpcollector) Hubs

 

This is also listed in the known issues and workarounds in the help documentation
snmpcollector Known Issues and Workarounds (broadcom.com)

 

 

Related KB: Upgrade Snmpcollector Best Practices (broadcom.com)