Upgrade Snmpcollector Best Practices
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Upgrade Snmpcollector Best Practices

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Article ID: 280657

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

I'm upgrading the snmpcollector probe and after the upgrade, I'm facing different issues:

•  The probe does not show a PID and port, but the snmpcollector is green.

•  Snmpcollector.mv.db is showing 0 KB

•  Snmpcollector is red and does not start

 

What are the best practices to upgrade snmpcollector without failures? 

Environment

DX UIM 20.4.* / 23.4

SnmpCollector 4.04 and later

Cause

Best Practices Guide

Resolution

To avoid these issues and prepare for a possible rollback/data recovery ensure you do the following steps when upgrading snmpcollector:

 

1. Deactivate the snmpcollector probe before performing the upgrade

Is quite important the SnmpCollector probe is deactivated during the upgrade to limit corruption issues. As mentioned in the docs: Upgrade snmpcollector (broadcom.com)

2. Backup the snmpcollector folder

Make a copy of the files included in the snmpcollector folder. This will ensure you can roll back and restore the previous DB files in case of unexpected corruption or failure during the upgrade. 

 

3. Avoid version "jumps" and follow the below upgrade path towards the latest version available (As per March 2024 snmpcollector GA Version is 4.13)

snmpcollector version upgrade path 4.04 > 4.05 > 4.06 > 4.11 > 4.12 > 4.13


NOTE: The GA Version is available for download in https://support.nimsoft.com, to get snmpcollector versions that is not GA, please log a support case with DX UIM

 

 

Additional Information