Tomcat probe doesn't connect to Spectrum OneClick tomcat server
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Tomcat probe doesn't connect to Spectrum OneClick tomcat server

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Article ID: 91787

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

I am trying to configure the tomcat probe to monitor my Spectrum OneClick servers - it fails with error message:

"Naming problem, reason: java.io.IOException: Failed to retrieve RMIServer stub: javax.naming.CommunicationException [Root exception is java.rmi.ConnectIOException: non-JRMP server at remote endpoint]: Failed to retrieve RMIServer stub: javax.naming.CommunicationException [Root exception is java.rmi.ConnectIOException: non-JRMP server at remote endpoint]"

 

 



and


"Unable to connect : example.com
i18nPDS desc value: Lost connection to the server?
i18nPDS resourcename value: example.com
Err token value: as#application.tomcat.resource_critical_error
resourcealarm: D, severity=5, message==The resource  <example> is not responding, subsystem=1.1.14.4.1, suppressionid=<example.com> source=<example.com>, alarm already scheduled to be sent."

When i try to use the Actions/Test function, it shows me ping error to the target server, but if i go to the command line of the robot server and manually ping the trget IP, I dont get a ping error: both of these servers are located in the same sub-net.

 

Environment

Robot server v7.93
Java version 1.8.0_102 

Java home C:\Program Files (x86)\Nimsoft\jre\jre8u102 
Java VM Oracle Corporation 

OS name Windows Server 2012 R2 

Tomcat probe: v1.3 

UIM v8.5.1 on a robot server running 

CA Spectrum OneClick server 
Operating system: Red Hat Enterprise Linux Server release 7.2 (Maipo) 

Cause

The possible causes of this issue can be:

1. Bad port defined in the connection details: 
2. Use of user name and password: must be blank
3. Spectrum server is missing the following lines:

jvm_opt=-Dcom.sun.management.jmxremote 
jvm_opt=-Dcom.sun.management.jmxremote.port=8008 
jvm_opt=-Dcom.sun.management.jmxremote.authenticate=false 
jvm_opt=-Dcom.sun.management.jmxremote.ssl=false 

In windows:
C:\win32app\Spectrum\tomcat\bin\OneClickService.conf 

In linux
$SPECROOT/tomcat/bin/catalina.sh 




Resolution

1. the port in the connection details should be 8008 (JMX default port)
2. Do not ser any username and password: must be blank
3. Verify the Spectrum server contains the following keys:

In windows:
C:\win32app\Spectrum\tomcat\bin\OneClickService.conf 

In linux
$SPECROOT/tomcat/bin/catalina.sh 

jvm_opt=-Dcom.sun.management.jmxremote 
jvm_opt=-Dcom.sun.management.jmxremote.port=8008 
jvm_opt=-Dcom.sun.management.jmxremote.authenticate=false 
jvm_opt=-Dcom.sun.management.jmxremote.ssl=false 

 

Additional Information

tomcat (Tomcat Server Monitoring) Release Notes:

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/ca-unified-infrastructure-management-probes/GA/alphabetical-probe-articles/tomcat-tomcat-server-monitoring/tomcat-tomcat-server-monitoring-release-notes.html

Related KB:

Connect to the cabi diagnostic port (Jasper Report Server) with the tomcat probe

https://knowledge.broadcom.com/external/article?articleId=204681