Option installation stuck as "In Progress" during SDM product update
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Option installation stuck as "In Progress" during SDM product update

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Article ID: 4020

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

If CA SDM is installed on a Windows environment that does not have Windows 8.3 file notation enabled, various components may fail.

You may see CA Service Desk Manager command line utilities such as pdm_load or pdm_options_mgr failing to run:

1. Pdm_load failing to run:

D:\CA\Servicedesk Manager\data>pdm_load -f tucson_insert.dat
Command - D:\CA\Service Desk Manager\bin\dbload tucson_insert.dat
'"Desk"' is not recognized as an internal or external command,
operable program or batch file.

2. Error caused by installing an Option via SDM interface:

03/01 15:01:54.64 [EXAMPLE SERVER]  bpnotify_nxd         5176 ERROR  bpnotify.c
            619 couldn't launch windows app: C:\Program Files (x86)/CA/
Service Desk Manager/bin/pdm_options_mgr -c -b -a pdm_option.inst  -o 1604  
-s multi_tenancy -v "setup" -d domsrvr -u superuser/someUserName

Where:

C:\Program Files/CA/Service Desk Manager is for "C:/PROGRA~1/CA/SERVIC~1"

C:\Program Files (x86)/CA/Service Desk Manager is for "C:/PROGRA~2/CA/SERVIC~1" 

3. The installation may fail as well, with "SDM Upgrade failed with exitCode - 1"   

Environment

CA Service Desk Manager R12.7, R12.9, 14.1

Windows operating systems

Cause

The cause of this is likely that Windows 8.3 file notation is disabled. The 8.3 file notation is a requirement for CA SDM and its components.

Resolution

1. To enable 8.3 File notation on a Windows 2008 server:

  1. Go to "Start" -> "Run"
  2. Type "Regedit"
  3. Navigate to "HKLM\SYSTEM\CurrentControlSet\Control\FileSystem"
  4. Change the value on "NtfsDisable8dot3NameCreation" to "0"
  5. Reboot the server.
  6. Verify the folder has a 8.3 notation available. For example: 

    C:\Program Files (x86)\CA>dir /X 
    Volume in drive C has no label. 
    Volume Serial Number is 24BF-3A18 

    Directory of C:\Program Files (x86)\CA 

    02/26/2013  04:50 PM    <DIR>                       .
    02/26/2013  04:50 PM    <DIR>                       ..
    11/20/2010  12:01 AM    <DIR>                       DCS
    06/18/2012  03:30 PM    <DIR>          DIRECT~1     Directory
    08/28/2007  07:11 PM    <DIR>          ETRUST~1     eTrust Antivirus
    02/26/2013  04:11 PM    <DIR>                       SC
    03/14/2013  01:16 PM    <DIR>          SERVIC~1     Service Desk Manager
    03/02/2011  11:22 AM    <DIR>          SHARED~1     SharedComponents
      0 File(s)              0 bytes
      8 Dir(s)   2,206,724,096 bytes free


    If you do not see the 8.3 notation available for that directory, you may need to reinstall CA SDM if this is a new installation.
  7. Verify the "%WINDIR%\paradigm.ini" file includes the 8.3 notation. 

    For example: 

    NX_ROOT=C:/PROGRA~1/CA/SERVIC~1 
    NX_LOCAL=C:/PROGRA~1/CA/SERVIC~1
  8. Start the CA Service Desk Manager Server service.
  9. Verify you can install the options in Options Manager

 

2. To enable 8.3 File notation on a Windows 2012 server:

First, you can use the FSUTIL.EXE tool to query the state of a volume.

  1. Enable 8.3 name creation (default for Windows Server 2012 is off) 

    C:\Users\Admin>fsutil 8dot3name set C: 0 
    Successfully set 8dot3name behavior.
  2. Verify the setting is now enabled as shown below: 
    C:\Users\Admin>fsutil 8dot3name query C: 
    The volume state for Disable8dot3 is 0 (8dot3 name creation is enabled). 
    The registry state of NtfsDisable8dot3NameCreation is 2, the default (Volume level setting). 
    Based on the above two settings, 8dot3 name creation is enabled on C:. 

    If you do not see the 8.3 notation available for that directory, you may need to reinstall CA SDM if this is a new installation.
  3. Reboot the server.
  4. Verify the folder has a 8.3 notation available. For example: 

    C:\Program Files\CA>dir /X 
    Volume in drive C has no label. 
    Volume Serial Number is 24BF-3A18 

    Directory of C:\Program Files\CA 

    02/26/2013  04:50 PM    <DIR>                       .
    02/26/2013  04:50 PM    <DIR>                       ..
    11/20/2010  12:01 AM    <DIR>                       DCS
    06/18/2012  03:30 PM    <DIR>          DIRECT~1     Directory
    08/28/2007  07:11 PM    <DIR>          ETRUST~1     eTrust Antivirus
    02/26/2013  04:11 PM    <DIR>                       SC
    03/14/2013  01:16 PM    <DIR>          SERVIC~1     Service Desk Manager
    03/02/2011  11:22 AM    <DIR>          SHARED~1     SharedComponents
      0 File(s)              0 bytes
      8 Dir(s)   2,206,724,096 bytes free

    If you do not see the 8.3 notation available for that directory, you may need to reinstall CA SDM.

  5. Verify the "%WINDIR%\paradigm.ini" file includes the 8.3 notation.
    For example:
    NX_ROOT=C:/PROGRA~1/CA/SERVIC~1
    NX_LOCAL=C:/PROGRA~1/CA/SERVIC~1
  6. Start the CA Service Desk Manager Server service.
  7. Verify you can install the options in Options Manager

Additional Information

KB Article 41397:  Options stuck in "In Progress" in options manager.