NSX Edge Bridge Profile Deletion task stuck "In Progress" State
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NSX Edge Bridge Profile Deletion task stuck "In Progress" State

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Article ID: 384241

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Updated On:

Products

VMware NSX

Issue/Introduction

  • In the NSX UI, you attempted to delete the Edge Bridge Profile.
  • The deletion task is stuck in the "In Progress" state, with no option to perform further actions.
    NSX Manager -> Networking -> Segments -> Profiles -> Edge Bridge Profile

  • You will notice the following errors in the NSX Manager logs,
    • /var/log/syslog
      2024-11-03T12:49:27.871Z <NSX Manager FQDN> NSX 77039 FABRIC [nsx@6876 comp="nsx-manager" errorCode="MP8923" level="ERROR" subcomp="manager"] Cannot delete BridgeEndpointProfile BridgeEndpointProfile/########-####-####-####-##############. It is being used by few bridge endpoints2024-11-03T12:49:27.872Z <NSX Manager FQDN> NSX 77039 POLICY [nsx@6876 comp="nsx-manager" errorCode="PM500015" level="ERROR" subcomp="manager"] ProviderInvocationTask: ########## - Failed to invoke provider L2BridgeEndpointProfileProviderNSXT
    • /var/log/proton/nsxapi.log
      2024-11-03T12:49:27.871Z ERROR providerTaskExecutor-1-33 BridgeEndpointProfileServiceImpl 77039 FABRIC [nsx@6876 comp="nsx-manager" errorCode="MP8923" level="ERROR" subcomp="manager"] Cannot delete BridgeEndpointProfile BridgeEndpointProfile/########-####-####-####-##############. It is being used by few bridge endpoints
      2024-11-03T12:49:27.872Z ERROR providerTaskExecutor-1-33 ProviderInvocationTask 77039 POLICY [nsx@6876 comp="nsx-manager" errorCode="PM500015" level="ERROR" subcomp="manager"] ProviderInvocationTask: ########## - Failed to invoke provider L2BridgeEndpointProfileProviderNSXTcom.vmware.nsx.management.switching.common.exceptions.SwitchingException: null
  • In some scenarios, also trying to create a new Edge Bridge Profile gets stuck in "Uninitialized".

Environment

VMware NSX 

Cause

When the Delete was attempted, there were still bridge endpoints attached to the Edge Bridge Profile, preventing the Edge Bridge Profile from being deleted. 

Resolution

  • Prior to removing the Edge bridge profile, remove any attached Edge bridge endpoints.

    To remove any attached Edge bridge endpoint follow the below steps.
  1. Run the API to review the Edge bridge endpoints profile being attached to any Edge bridge endpoint profile.
    GET /api/v1/bridge-endpoints

    Check the  "bridge_endpoint_profile_id" field, the ID will be the same as the affected Edge bridge profile ID.

  2. Confirm that this Bridge endpoint is no longer needed, and then delete the Edge bridge endpoint with the API
    DELETE /api/v1/bridge-endpoints/<bridgeendpoint-id>

    If it returns "200 OK" then go to step 3.

    If the Bridge endpoint deletion fails with the error message as "BridgeEndpointProfile: BridgeEndpointProfile/<UUID> is in use. Cannot be deleted. Please use the object name or UUID in Global Search to find all linked objects". Then go to step 4

  3. Delete the Edge bridge profile with the below API and refresh the page.
    DELETE /api/v1/bridge-endpoint-profiles/<bridgeendpointprofile-id>

    If the API returns "200 OK", refresh the page, and the Edge bridge endpoint profile should be removed. If it still shows "In progress". Perform a rolling reboot of the NSX managers.

  4. Perform a global search with the UUID you found in the error message in step 3, if it is attached to a Logical-port. Run the below API
    GET /api/v1/logical-ports/<logical-port-id>
  5. Delete the Logical port using the below API
    DELETE /api/v1/logical-ports/<logical-port-id>

    If the API returns an error as Bad request, go to step 8 or if the API returns "200 OK" go to step 6.



  6. Now, you can delete the Edge bridge endpoint using the below API
    DELETE /api/v1/bridge-endpoints/<bridgeendpoint-id> 
  7. Delete the Edge bridge endpoint profile using the below API
    DELETE /api/v1/bridge-endpoint-profiles/<bridgeendpointprofile-id>

    If the API returns "200 OK", refresh the page, and the Edge bridge endpoint profile should be removed. If it still shows "In progress". Perform a rolling reboot of the NSX managers.

  8. Remove the "Attachment" from the Logical port configuration using the below details collected in step 4
    PUT /api/v1/logical-ports/<logical-port-id> 

    In the body, put the Logical port configuration and remove the "Attachment field with its value" from the Logical port.

    If the PUT api fails with a permission issue, add the header as Type = "X-Allow-Overwrite" Value = true If it returns "200 OK" follow steps 5 to 7

If you have attempted the above steps and the Edge bridge endpoint profile is still showing "In Progress" status, please open a support case with Broadcom Support and refer to this KB article.
For more information, see Creating and managing Broadcom support cases.

Additional Information

If you are contacting Broadcom support about this issue, please provide the following:

  • NSX Manager support bundles.
  • Text of any error messages seen in NSX GUI or command lines pertinent to the investigation.

Handling Log Bundles for offline review with Broadcom support