Unable to log in to Performance Management Portal as the default Admin user
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Unable to log in to Performance Management Portal as the default Admin user

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Article ID: 32139

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Updated On:

Products

CA Infrastructure Management CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

Using the default admin user and password unable to log in to the Performance Center UI

Environment

All supported Performance Management releases

Cause

If the default password doesn't work, one of two things may have happened.

  1. The default admin user in CA Performance Center (CAPC) comes with the Authentication Type set to 'Performance Center'. If this is mistakenly changed to 'External', the users log in will fail after the change is made. If there is no other admin user created against the Administrator Role, there will be no ability at that point to gain access to the CAPC web UI. This is because the user is trying to authenticate through an outside, external source and fails to do so.
  2. The password was changed and is unknown.

Resolution

The only way to resolve this is with two MySql queries against the netqosportal DB on the PC host.

REST can't be used at this point since it relies on the admin users log in details to engage the PC host for REST based requests.

Solution for Cause #1: Authentication type changed

To resolve cause number 1 above where the admin users authentication was changed, we will need to update both the Authentication Type and the password for the default admin user to resolve this. This is because when the Authentication Type is set to External, the users password is reset to the encrypted form of a blank password.

In that situation complete the following:

  1. Open a terminal window to the CAPC host and log in as the root, or sudo-root install owner

  2. Go to the directory $CAPC_HOME/CA/Mysql/bin. The default path would be /opt/CA/Mysql/bin

  3. Connect to MySql by running the command "./mysql -uroot -p netqosportal". Enter the mysql password set on install.

  4. Run these two queries to modify the necessary values and resolve this.
    1. First the query to set the Authentication Type to the correct value:
      • UPDATE user_definitions SET AuthType=1 where UserId = 1;

    2. Next we update the password back to the default 'admin' password value:
      • For versions prior to 21.2.6:

        UPDATE user_definitions SET Password = '21232f297a57a5a743894a0e4a801fc3' where UserId = 1;

        OR

        update user_definitions set password=MD5('NEW-PASSWORD') where name='admin';
      • On 21.2.6 and later:

        UPDATE user_definitions SET Password = 'edbd881f1ee2f76ba0bd70fd184f87711be991a0401fd07ccd4b199665f00761afc91731d8d8ba6cbb188b2ed5bfb465b9f3d30231eb0430b9f90fe91d136648' where UserId = 1;

  5. Once those changes are made, run the command "\q" to exit the MySql prompt.

We should now be able to once more log in to the PC UI as the default admin user using the default password "admin".

 

Solution for Cause #2: Unknown password, reset required

To resolve cause number 2 we simply reset the admin users password. It's the same solution as above, minus the command to change the authentication type.

In that situation complete the following:

  1. Open a terminal window to the CAPC host and log in as the root, or sudo-root install owner
  2. Go to the directory $CAPC_HOME/CA/Mysql/bin. The default path would be /opt/CA/Mysql/bin
  3. Connect to MySql by running the command "./mysql -uroot -p netqosportal". Enter the mysql password set on install.
  4. Run this query to modify the password back to the default encrypted value.
    • For versions prior to 21.2.6:

      UPDATE user_definitions SET Password = '21232f297a57a5a743894a0e4a801fc3' where UserId = 1;

      OR

      update user_definitions set password=MD5('NEW-PASSWORD') where name='admin';


    • On 21.2.6 and later:

      UPDATE user_definitions SET Password = 'edbd881f1ee2f76ba0bd70fd184f87711be991a0401fd07ccd4b199665f00761afc91731d8d8ba6cbb188b2ed5bfb465b9f3d30231eb0430b9f90fe91d136648' where UserId = 1;
       
    •  This will set the password to "admin"
  5. Once that change is made run the command "\q" to exit the MySql prompt.

Additional Information

If still unable to log in to PC/Portal web page, review the /opt/CA/PerformanceCenter/PC/logs/PCService.log file. In case you have entry like this:

WARN  | qtp263696733-28          | 2023-03-01 09:48:03,771 | com.ca.im.portal.services.user.UserAuthenticationServiceImpl
      | Unable to determine auth type for user 'admin' -- UserAuthentication - Account is disabled. 

Run these MySQL commands:

select UserLevel, Name, Enabled from user_definitions where Name = 'Admin';
UPDATE user_definitions SET Enabled = 'Y', UserLevel = '1' where UserId = '1';

OR follow the steps from KB: https://knowledge.broadcom.com/external/article?articleId=248358