Migrating agents to new GSS server names computers as New_Computer and these have no inventory data
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Migrating agents to new GSS server names computers as New_Computer and these have no inventory data

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Article ID: 261631

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Updated On: 01-04-2024

Products

Ghost Solution Suite

Issue/Introduction

When migrating computers from one GSS 3.3 RU10 server to a new GSS 3.3 RU10 server, when entering the server name or IP under Change Agent Settings > Production Agent the endpoint displays in the GSS Console as New_Computer and not the desired Display Name. 

Upon going to the endpoint's properties in the Console there is no inventory data. 

Environment

GSS 3.3

Cause

Something caused a "config-failed" condition that the DAgent logs didn't capture but the registry key "HKLM\SOFTWARE\Altiris\Client Service" has a value set to "config-failed=1".  This registry key value causes full inventory not to be sent.  The default value of this key is "config-failed=0".

Resolution

There are two resolutions options and both use the registry key "HKLM\SOFTWARE\Altiris\Client Service" with value of "config-failed=x":

  1. For machines that have already been migrated, you can either delete the "config-failed" key value or change it back to the default ("config-failed=0" which "false") and this will force the inventory to be sent again (a DAgent service restart may be needed).
  2. For machines that have not yet been migrated, you will need to change the registry value back to the default of "config-failed=0"  first and then migrate again.

NOTE: If many machines are affected you could create a .req script file and send it to all affected endpoints which should resolve this issue.

Additional Information

How to move clients from old GSS server to new GSS server