Management Center unable to connect to Reporter with "Unknown Error"
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Management Center unable to connect to Reporter with "Unknown Error"

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Article ID: 253233

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Updated On:

Products

Management Center Management Center - VA

Issue/Introduction

Management Center unable to connect to Reporter with "Unknown Error"

Environment

Management Center and Reporter running supported version.

Cause

Reporter  is in inactive or failed state. 

reporter# reporter-status
    inactive (dead) since Mon 2022-10-31 10:32:12 UTC; 4s ago
reporter#
reporter# reporter-status
    failed (Result: exit-code) since Mon 2022-10-31 10:39:59 UTC; 32min ago
reporter#

Management Center requires Reporter service to be in active (running) state to be managed.

Example:

reporter# reporter-status
    active (running) since Mon 2022-10-31 11:38:32 UTC; 2s ago
reporter#

Resolution

Following options are available:

  • Start reporter:

https://techdocs.broadcom.com/us/en/symantec-security-software/web-and-network-security/reporter/11-0/reporter-reference/Rptr_CLI/enable-mode-commands/start-reporter.html

  • If service is in failed state, restore to previous settings:

https://techdocs.broadcom.com/us/en/symantec-security-software/web-and-network-security/reporter/11-0/reporter-reference/Rptr_CLI/enable-mode-commands/restore-settings.html

Note: You'll need to stop-reporter prior restore-settings, then start the service.   Run reporter-status again to see if the backup settings chosen worked. 

 

If above options were unsuccessful rebuild of reporter may be needed:

  • For hardware Reporter:

https://knowledge.broadcom.com/external/article/240044/how-to-factory-reset-reporter-appliance.html

  • For Reporter VM - redeploying new Virtual Machine

Note: New database must be built using the new access logs from Edge SWGs.   Creating a database that would report previous dates is only possible if there are  backups of raw access logs located on different server (FTP, http, etc.)

 

Additional Information

If the Management Center GUI displays the error "The credentials provided are not authorized" due to an unexpected restart of the Reporter, and you are unable to use reporting features, please remove and then re-add the Reporter.

Even if you remove the Reporter, the reports, databases, and settings stored on the Reporter will not be lost. 
Everything will return to its original state once it is re-added.

Furthermore, any reports exported and saved on the Management Center will remain intact, and scheduled jobs will continue to run normally after the Reporter is re-added.