Schedule errors: "Monthly trigger is missing week or contains week with invalid value"
search cancel

Schedule errors: "Monthly trigger is missing week or contains week with invalid value"

book

Article ID: 232896

calendar_today

Updated On: 03-26-2025

Products

IT Management Suite

Issue/Introduction

Noticed that while creating a custom schedule for the Software Delivery Task or Windows System Assessment Scan policy, it will fail with "Monthly trigger is missing week or contains week with invalid value".

Steps to reproduce:

  1. Windows System Assessment Scan policy, add schedule > Schedule Time
  2. Configure repeat, Month (Week view), select week 3 and Sunday
  3. Save, and update policy on the client machine (both Patch and SWD plugins installed)
  4. Try to execute the SWD task (or policy), observe the SWD can't complete with error:
    "Monthly trigger is missing week or contains week with invalid value"

Environment

ITMS 8.x

Cause

Known issue. Both Patch and Software Management Framework agents use the newer scheduler to schedule the tasks.

The newer scheduler has been fixed to correctly process comma-delimited weeks.

Resolution

This issue has been resolved in ITMS 8.6 RU2 release.

The following KB articles list the pointfixes available for pervious ITMS 8.x versions:

215121 CUMULATIVE POST ITMS 8.6 RTM (GA) POINT FIXES

221269 CUMULATIVE POST ITMS 8.6 RU1 POINT FIXES