After upgrading to 8.6 RU1 update console is experiencing freezes and in logs constantly refer to collection 'UNIX/Linux/Mac Computers Requiring Symantec Management Agent Upgrade'
search cancel

After upgrading to 8.6 RU1 update console is experiencing freezes and in logs constantly refer to collection 'UNIX/Linux/Mac Computers Requiring Symantec Management Agent Upgrade'

book

Article ID: 225706

calendar_today

Updated On:

Products

Client Management Suite IT Management Suite

Issue/Introduction

After upgrading to 8.6 RU1, we observe an issue with the console: 

  • Some settings menu make the console freeze
  • SMP Logs following error messages are logged:

Failed to perform a collection membership update on the collection 'UNIX/Linux/Mac Computers Requiring Symantec Management Agent Upgrade' (edc60302-f96a-4bbc-9b68-402eaead63d5). An unhandled exception has occurred.

Failed to perform operation: Updating resource targets (view), current="%View item guid%"

Environment

ITMS 8.6 RU1

Cause

Environmental. Most likely caused by the large number of resources managed by the SMP Console

Resolution

A fix for this issue is documented in the ITMS 8.6 RU2 release.

A pointfix for 8.6 RU1 is available under KB “CUMULATIVE POST ITMS 8.6 RU1 POINT FIXES

Workaround:

For the workaround in SQL run following query to allow us to Edit it:

update item set Attributes='0' where guid = 'edc60302-f96a-4bbc-9b68-402eaead63d5'

Then in Console go to Manage > Filters > Software Filters > Agent and Plugin-in Filters > and find the 'UNIX/Linux/Mac Computers Requiring Symantec Management Agent Upgrade' Filter. It now should be Editable.

Select Edit and in the Parameterized Query field, replace the content with the following:

declare @lastVersion nvarchar(20) set @lastVersion = (SELECT MAX (Version) FROM dbo.SmpVersions d, Inv_AeX_AC_Client_Agent a WHERE d.PluginGuid= a.[Agent Class Guid] AND a.ProgId='Altiris.PluginManager')
SELECT DISTINCT v1.Guid FROM vRM_Computer v1
INNER JOIN Inv_AeX_AC_Identification id ON id._ResourceGuid = v1.Guid
INNER JOIN Inv_AeX_AC_Client_Agent t1 ON v1.Guid = t1._ResourceGuid
CROSS APPLY dbo.fnSysMask_GetAllSystemMaskAsTable(id.[OS System Mask]) sm
WHERE v1.IsManaged=1
AND sm.[Platform] & ( 2 + 4 + 32 ) != 0
AND (((LOWER(t1.[Agent Name]) LIKE '%altiris agent%'
OR LOWER(t1.[Agent Name]) LIKE '%altiris express unix ns agent%'
OR t1.[Ident] = 'NSAGENT')
AND (dbo.fnAltiris_Agent_Unix_CompareVersion(t1.[Product Version], @lastVersion ) < 0))
OR (LOWER(t1.[Agent Name]) LIKE '%altiris%mac%inventory%solution%'
AND (dbo.fnAltiris_Agent_Unix_CompareVersion(t1.[Product Version], '6.1') > 0)))

And Save changes.

Then it is recommended to perform IISReset (to remove cached version) and see if these changes fix this issue.