Error: Symantec Installation Manager detected that TLS1.0 is not enabled on this machine and Microsoft .NET is not configured to support this configuration.
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Error: Symantec Installation Manager detected that TLS1.0 is not enabled on this machine and Microsoft .NET is not configured to support this configuration.

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Article ID: 224811

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Updated On:

Products

IT Management Suite

Issue/Introduction

When applying a license in Symantec Installation Manager (SIM) the following error is seen: 

Symantec Installation Manager detected that TLS1.0 is not enabled on this machine and Microsoft .NET is not configured to support this configuration.  
Required configuration steps are specified in TECH272111.  
Selected operation can't be initiated.

Environment

ITMS 8.x

Cause

TLS was improperly configured for the operating system in the registry.

Resolution

The KB referenced in the message above is actually a legacy Symantec KB number and the new Broadcom KB number for this article is:

172898 Failing to install ITMS. ConfigureNS - task_Completed(): Configuration Task Pre-Configuring ... Failed: The underlying connection was closed: An unexpected error occurred on a send.

The RESOLUTION is to check the following registry keys to verify that they are set correctly and then stop & start SIM again.  Here are the steps:

  1. Add (or modify if these already exist) the following registry keys with the specified values (save to .reg file and execute, if desired):

    a. Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\.NETFramework\v2.0.50727]
    "SystemDefaultTlsVersions"=dword:00000001
    "SchUseStrongCrypto"=dword:00000001

    [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\.NETFramework\v4.0.30319]
    "SystemDefaultTlsVersions"=dword:00000001
    "SchUseStrongCrypto"=dword:00000001

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v2.0.50727]
    "SystemDefaultTlsVersions"=dword:00000001
    "SchUseStrongCrypto"=dword:00000001

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319]
    "SystemDefaultTlsVersions"=dword:00000001
    "SchUseStrongCrypto"=dword:00000001

  2. Restart SIM.
  3. Try to install it again.

Additional Information

199465 "SIM is no longer able to download files over HTTP requests. Access to solutionsam.com is to be limited to HTTPs only."