AIOps - Unable to login due to USER PASSWORD IS LOCKED
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AIOps - Unable to login due to USER PASSWORD IS LOCKED

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Article ID: 212059

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Updated On:

Products

DX Operational Intelligence CA App Experience Analytics DX Application Performance Management

Issue/Introduction

Symptoms
 
-When trying to login to http://<apmservices-gateway>/dxiportal/#/dxiportal/login you get message
 
"Failed to login. Verify that user ID and password are correct" 

in developer tool the below error message is reported : "GENERIC_SERVICE_ERROR"

 

-When trying to login to http://<doi-adminui>/admin/maa/#/login you get message

"USER PASSWORD IS LOCKED PLEASE CONTACT THE SYSTEM ADMINISTRATOR




Environment

DX Operational Intelligence 1.3.x, 20.2.x
DX Application Performance Management 11.x, 20.2.x
DX AXA 20.2.x

Cause

Account is locked

 

How to verify this condition?

a) obtain the postgres pod name

kubectl get pods -n<namespace> | grep postgres

Example:

kubectl get pods -ndxi | grep postgres
dxi-postgresql-bccdd4475-86z4d                        1/1       Running     0          34d

b) exec postgres pod

kubectl exec -it <postgres-pod> -n<namespace> bash

Example:

kubectl exec -it dxi-postgresql-bccdd4475-88fqw -ndxi bash

 
c) connect to aoplatform database

psql -U aopuser -d aoplatform


d) strikecount value should be 0

SELECT strikecount FROM aradminbasicauthuser WHERE userid = '<USER-NAME (IN UPPERCASES)>';


Below is an example when MASTERADMIN account is locked:

SELECT strikecount FROM aradminbasicauthuser WHERE userid = 'MASTERADMIN';

strikecount
-------------
        5
(1 row)

Below is an example when a SUPPORT account is locked:

SELECT strikecount FROM aradminbasicauthuser WHERE userid = 'SUPPORT';
 strikecount
-------------
          5
(1 row)

Resolution

Unlock the user account using the below SQL Update statement:

UPDATE aradminbasicauthuser SET strikecount = 0 WHERE userid = '<USER-NAME (IN UPPERCASES)>';

Examples:

UPDATE aradminbasicauthuser SET strikecount = 0 WHERE userid = 'MASTERADMIN';

Or

UPDATE aradminbasicauthuser SET strikecount = 0 WHERE userid = 'SUPPORT';

Additional Information

DX AIOPs - Troubleshooting, Common Issues and Best Practices
https://knowledge.broadcom.com/external/article/190815