Unable to install Deployment Task Server Handler on Site Server
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Unable to install Deployment Task Server Handler on Site Server

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Article ID: 207317

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Updated On:

Products

Deployment Solution

Issue/Introduction

The customer has a Site Server where he can't install Deployment Task Server Handler.

"Deployment Solution Plug-in" is installed since it is required.

The Site Server is getting the required policy to install it: "Deployment Task Server Components (x64) - Install"

The agent logs show that the policy runs and no errors when the install package runs are noticed. Even the TSHmsi.log (under C:\ drive) no show errors saying that the installation failed.

We even tried to remove and reinstall the Symantec Management Agent but still no luck in getting "Deployment Task Server Handler" listed as installed.

We even tried running Symantec_DeploymentSolutionTaskServerHandler_8_5_x64.msi (using 8.5 version as eample) manually but still no luck.

 

Environment

ITMS 8.x

Cause

There was a previous installation of "Deployment Task Server Handler" that didn't remove everything needed from the registry.

From the THSmsi.log:
MSI (s) (6C:74) [21:28:19:429]: Product registered: entering maintenance mode

It seems that there is a corrupt instance of Deployment Task Server Handler (DSTH for short) already installed.

 

Note:
Make sure the "Altiris Client Task Server Agent" is installed. Otherwise it could cause the installation process to display "Skipped after detection check" status.

Resolution

  1. Try to run the following command line on the Task Server to view all instances of DSTH:

    wmic product where "name = 'Deployment Solution TaskServer Handler'"


    For this example, this is what the command above returned:


    which indicated they had another installation already present, one with just the entry and the second one with the most recent msi reference in C:\Windows\Installer :

    Entry 1:

    1               Deployment Solution TaskServer Handler  Deployment Solution TaskServer Handler                                      {BA19D175-824C-4987-9290-CF453803C6E8}                                                                                                                                                                                                                          1             1033                                         Deployment Solution TaskServer Handler                                     {28807531-F0EF-4B21-9795-4C8FB0271446}  Symantec_DeploymentSolutionTaskServerHandler_8_5_x64.msi       

     

    Entry 2:

    1               Deployment Solution TaskServer Handler  Deployment Solution TaskServer Handler  [email protected]  801 226 8500   {BAB3383E-ACD2-4306-BC36-19D811C9ABA0}  20200821                   C:\Program Files\Altiris\Altiris Agent\Agents\Deployment\  C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery

    {B5786691-3E11-4FCB-9F18-831EEB5C778C}

    \cache\  5             1033      C:\Windows\Installer\6cc0a842.msi  Deployment Solution TaskServer Handler  C:\Windows\Installer\6cc0a842.msi  {F2DFC440-71C5-4F70-999E-83B00A08C5A7}  Symantec_DeploymentSolutionTaskServerHandler_8_5_x64.msi                                                          http://www.altiris.com  http://www.altiris.com  Symantec  8.5.5710.0  2



  2. If the result from cmd above is not empty, try to remove any reference of this installation from C:\Windows\Installer\ and the registry.

    Using the results from the example above, we looked for " C:\Windows\Installer\6cc0a842.msi " and uninstalled it (right-click>uninstall).  Also, we found another msi reference in the same directory.

    When we tried to uninstall the second reference, it failed because it couldn't find the source file.
    So, we went to the registry and we searched for 'Deployment Solution TaskServer Handler'.

    We found two entries:

    HKEY_CLASSES_ROOT\Installer\Products\571D91ABC42878942909FC5483306C8E

    HKEY_CLASSES_ROOT\Installer\Products\E3833BAB2DCA6034CB63918D119CBA0A

    We deleted both.

  3. After cleaning up previous installation references, run the command line again. This time it shouldn't find any current installation:

    C:\Administrator>wmic product where "name = 'Deployment Solution TaskServer Handler'"

    No Instance(s) Available.

  4. After that, run the install policy "Deployment Task Server Components (x64) - Install" again.   'Deployment Solution TaskServer Handler' should appear as installed under Agent Settings.



Note:
The same issue could happen for "Deployment Package Server" plug-in. 
Follow the same steps above but instead use the following command:

wmic product where "name = 'Deployment Solution Package Server'"

and search the registry for Deployment Solution Package Server.

 


Another approach:

Missing version in wmic output for 8.5.3660 msi instance indicates corrupt installation.

Normally in such case, one needs to obtain a good (known working) copy of msi file with exactly the same version, and install it with additional switch '/fa'.

The '/fa' should force ignore of msi stored at installer cache (C:\Windows\Installer), and helps to repair existing instance.

Additional Information

191333 "error: COM object 'DeploymentSolutionAgent_Task' is not found, make sure the corresponding plug-in or task handler module is installed and registered"