error: COM object 'DeploymentSolutionAgent_Task' is not found, make sure the corresponding plug-in or task handler module is installed and registered
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Article ID: 191333
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Updated On:
Products
IT Management SuiteDeployment Solution
Issue/Introduction
The following error message is displayed in the agent logs while trying to run a task:
Error 1: CClientTaskInstance::Execute(): CAtrsException exception, error: COM object 'DeploymentSolutionAgent_Task' is not found, make sure the corresponding plug-in or task handler module is installed and registered, OS error: Cadena clase no válida (0x800401F3), at line 71 re-throw at CAtrsComPtr::CoCreateInstance re-throw at CAtrsComPtr::CoCreateInstance(BSTR) re-throw at CClientTaskInstanceWin32::_CreateTaskHandler re-throw at CClientTaskInstanceBase::_CreateTaskHandler re-throw at CClientTaskInstanceBase::_Execute ----------------------------------------------------------------------------------------------------- Date: 5/19/2020 3:29:36 PM, Tick Count: 1565267 (00:26:05.2670000), Size: 766 B Process: AeXNSAgent.exe (3592), Thread ID: 700, Module: client task agent.dll Priority: 1, Source: CAtrsException
Error 2: CTaskExecutionEngineBase::_onProcessExecuteTask(): CAtrsException exception, error: Failed to execute task, COM object 'DeploymentSolutionAgent_Task' is not found, make sure the corresponding plug-in or task handler module is installed and registered, OS error: Cadena clase no válida (0x800401F3), at line 541 re-throw at CTaskExecutionEngineBase::_onProcessExecuteTask re-throw at CTaskExecutionEngineBase::_onProcessExecuteTask re-throw at CTaskExecutionEngineBase::_onProcessExecuteTask ----------------------------------------------------------------------------------------------------- Date: 5/19/2020 3:29:36 PM, Tick Count: 1565267 (00:26:05.2670000), Size: 737 B Process: AeXNSAgent.exe (3592), Thread ID: 700, Module: client task agent.dll Priority: 1, Source: CAtrsException
Environment
ITMS 8.1, 8.5
Cause
Usually these messages refer to one of these two common reasons: 1. Either you are missing the deployment plugin on the client, 2. or the task server doesn't have the DSTaskhandler installed that it is connected to.
Resolution
The error message indicates a Deployment Solution task cannot be processed and the common cause for that is missing Deployment Plugin on the client or missing DS Task Handler on the Task Server this client is registered to.
Plugin versions can be checked either from the Agent UI on the machines themselves or Plug-in Versions section of "Manage > Computers" in the Symantec Management Console (assuming the machines are otherwise reporting back to SMP properly).
The policies for the plugins are:
1. Make sure your client machine has the Deployment Solution Plug-in installed:
Agent Plug-in (client) install: Settings > Agents/Plug-ins > All Agents/Plug-ins > Deployment > Windows (x64) > Deployment Plug-in for Windows (x64) > Install/Upgrade
2. Make sure the Task Server servicing this client(s) has the Deployment Task Server Handler installed:
Task Server components: Settings > Agents/Plug-ins > All Agents/Plug-ins > Deployment > Windows (x64) > Deployment Task Server Components (x64) > Install/Upgrade
If the plugins are there, please verify that the versions match and upgrade if necessary: KB 150933 "What are the released ITMS 8.5 Agent or Plug-in versions and build numbers?"
If that does not help please try reinstalling Deployment Plug-in on the client machine, or the entire Agent if the plug-in reinstall does not help.
Additional Information
207317 "Unable to install Deployment Task Server Handler on Site Server"