Error: "Unexpected error has occurred" or "Unable to communicate to the PPM server" after updating Chrome to 83.0.4103.61
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Error: "Unexpected error has occurred" or "Unable to communicate to the PPM server" after updating Chrome to 83.0.4103.61

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Article ID: 191277

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

After upgrading to one of the following browser versions, you see the error "An unexpected error has occured" or "Unable to communicate to the PPM server".

  • Chrome build 83.0.4103.61
  • Microsoft Edge Chromium-based build 83.0.478.44 

Environment

  • Release  All supported releases
  • Component: CA PPM INTEGRATIONS & INSTALLATIONS
  • Browsers:
    • Google Chrome build : 83.0.4103.61
    • Microsoft Edge Chromium based build 83.0.478.44

Cause

This issue is caused by the Chrome defect Issue 1084874: async form submission change breaks site expecting first load event for just-created iframe to be for the form submission

This generic error may occur when performing one of the following steps or actions:

  • Logging in via Classic PPM.
  • Navigating within Classic PPM (e.g. clicking Next).
  • Clicking Save and Return on a task.
  • Creating a new project and clicking Save.
    • Note: Additional new project is also created if you click Close to the popup versus 'X'
  • Clicking Add on the Task list.
  • Clicking Filter on a portlet/page list.
  • Searching for documents in the knowledge store or through global search.
  • Attaching files.

Other things you may notice:

  • Cost plans do not copy over during idea conversion and the Department lookup is not populated.
  • This issue does not happen in the New User Experience aside from working in a Channel that links to a Classic PPM.
  • Nothing is found in the app-ca.logs related to this issue.

Resolution

Chrome bug 1084874 has been fixed in Chrome and backported to the latest 83 build available:

Chrome

Fixed in 83.0.4103.97 (and higher). To get this update in Chrome, go to Help > About Google Chrome (chrome://settings/help).

Note: If you don't see the update, it's likely restricted by your company. Contact your internal GIS team to request this build.

Microsoft Edge

Fixed in 83.0.478.45 (and higher). To get this update in Edge, go to Help and Feedback > About Microsoft Edge.

Note: See Release notes for Microsoft Edge Stable Channel for more details on this release.

Additional workarounds

Workaround 1

Click X (recommended) on the popup error window instead of Close, as Close may cause a few additional issues such as:

  • This action may take you back to the previous action.
  • In project creation, this action may create an additional new project.

Workaround 2

Use a different browser configuration, such as:

  • IE 11. Exception: If on 15.4.1 base option is to use Firefox only due to defect 103910
  • Use Microsoft Edge Chromium with IE integration
  • Use an older version of Chrome
  • Install the Chrome IE extension
  • Use Firefox

Workaround 3

Use the New User Experience, if possible, as the issue hasn't been reproduced there aside from working in a Channel that links to a Classic.

Workaround 4

If you haven't already upgraded, change your system policy to not auto-upgrade Chrome.

Additional Information

Steps to reproduce

Reproduce using project creation as an example

  1. Upgrade your Chrome version to 83.0.4103.61.
  2. In Clarity, go to Home > Projects.
  3. Click New.
  4. Enter the required information and click Save.
  • Expected Results: The action (project creation) completes without error.
  • Actual Results: You see the error "Unable to communicate to the PPM server. Please try again and if problem persists contact your system administrator".

Reproduce using Idea conversion example

  1. Create an idea.
  2. Financially enable it by adding a department.
  3. Create a cost plan on the idea.
  4. Submit the idea for approval.
  5. Approve the idea.
  6. Convert the idea using the below steps:
    1. Click the Convert button on the idea.
    2. For Investment type, select Project from the template and click Next.
    3. The popup error occurs. Click Close.
    4. You are taken to an unexpected Error page. Click Back.
      • Error: "Error on page: System error. Contact your system administrator."
    5. Click Close.
    6. Enter the project name and other required fields and click save.
    7. Click Close to the Unable to communicate to the PPM Server message.
    8. Click the Financial Plans tab.
  • Expected Results: Cost Plan appears
  • Actual results: Cost plan isn’t copied over and instead you get Error: You must associate this investment with an entity before a financial plan can be set up.
    (This error is due to the Department not getting populated automatically in the new project, it populates successfully in earlier versions of Chrome.)

Additional actions