Troubleshoot web browser / application connectivity or errors using Fiddler
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Troubleshoot web browser / application connectivity or errors using Fiddler

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Article ID: 170523

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Updated On:

Products

Cloud Secure Web Gateway - Cloud SWG

Issue/Introduction

Web pages or applications are failing to connect, getting errors, or intermittent disruptions. 
 
You may be having unexpected results with a web page or application, such as:
  • Some areas or images do not load or appear to be blocked.
  • A website may be unreachable from one data center but not another or for one user but not another.

Environment

Cloud SWG (WSS - Web Security Service)

Cause

Supported Technologies

Any Browser
Telerik Fiddler web debugging proxy helps you record, inspect and debug traffic from any browser.


Any System

Debug web traffic from any Windows-based PC, Mac or Linux system and mobile devices alike.
 
Debug traffic from PC, Mac or Linux systems and mobile devices. Ensure the proper cookies, headers and cache directives are transferred between the client and server. Supports any framework, including .NET, Java, Ruby, etc.
Fiddler is a free web debugging proxy which logs all HTTP(s) traffic between your computer and the Internet. Use it to debug traffic from virtually any application that supports a proxy like Chrome, Safari, Firefox, Edge, IE, Opera and more.

Resolution

Here are the instructions on how to obtain Fiddler and take the trace.

IMPORTANT: Fiddler should be installed on the user's workstation.

The Fiddler Web Debugging Proxy program was originally developed by Microsoft and is now owned by Telerick.  It is free for all use. You may download it from www.telerik.com/fiddler.

Download:

  1. Select Fiddler Classic 
  2. Fill out the rest of the form
  3. Click on Download Fiddler to download and install it.
  4. Click on save
  5. Click on the downloaded file to start the installation.

Usage:

  1. Start Fiddler using the Fiddler2 icon in your START | Programs menu.
    If the https communication is used, it is necessary to follow the below steps. If the http communication only is used, go to #2.
    a) Tools > Options... 

    b) Check the below check box and select the below item in the dropdown box in the HTTPS tab, and click OK button.
        - Capture HTTPS CONNECTS
        - Decrypt HTTPS traffic
        - Select '... from all processes' in the dropdown box.
    IMPORTANT: Trust the Fiddler Root certificate. TEMPORARY only for testing. Do Not Trust FiddlerRoot certificate permanently.

    When using Fiddler with WSS Agent, please refer to the following for additional information when collecting data: Fiddler does not work when WSSA is installed


       

  2. Replicate the issue with the application or web page in the browser.

  3. In the left hand pane of fiddler you should see the requests and responses.

  4. To save these in the format needed by Broadcom support,
  • Select File from the top left menu
  • Choose Save-> All Session(s) 
  • Fill in a file name for the trace
  • Click Save
  • The file will be saved with the default SAZ extension.