PXE Configuration Utility on GSS server shows a re-installed PXE server is in 'Offline' with red exclamation mark next to it.
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PXE Configuration Utility on GSS server shows a re-installed PXE server is in 'Offline' with red exclamation mark next to it.

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Article ID: 154088

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Updated On:

Products

Ghost Solution Suite

Issue/Introduction

After performing a clean un-install of the PXE server, and after restarting the Ghost Solution Suite Server, the  PXE server shows up with the status of  'Offline' with a red exclamation mark next to it in the PXE Configuration utility Status tab.

After a clean un-install and re-install, the PXE Server shows in the "Offline" state in the PXE Configuration utility Status tab.

Environment

GSS 3.x.x

Cause

If the PXE server is not un-installed cleanly or if the there are any network issues with the Ghost Solution Suite Server, the PXE server will display as "Offline" under PXE Configuration Utility >Status tab.

Resolution

Before continuing with the steps below, refer to the following KB:

https://knowledge.broadcom.com/external/article?articleId=421144

If that article doesn't resolve your problem, continue to the steps below:

1. If you have any of your PXE Boot Images 'redirected' and only available on the remote PXE server you want to remove from the list, delete those PXE configurations before continuing.

2. Stop all PXE services on the main PXE Manager server:
- PXE Server
- PXE Config Helper (which should stop the rest)

3. Open the 'eXpress' share (\Program Files (x86)\Altiris\eXpress\Deployment Server) and then navigate to the PXE directory/folder.

4. Make a backup/copy of the file PXEManager.ini file and save it off of the eXpress share.

5. Open PXEManager.ini with a text editor and search for the name of the PXE server that needs to be removed from the PXE Configuration Utility. The first result should find a line similar to below:

[PXEServer\{GUID}\Server]
ServerName="RemotePXE"
ServerIPAddr="10.1.1.3"
HasCustom=False

6. If the first search result is showing a 'BootMenu' option instead, refer to step 1 and delete any PXE configurations built only for the remote PXE server first (PXE Configuration Utility > File > Chose PXE Server > Select the PXE server that needs to be removed > find any configurations with 'Scope' of 'local' and delete the configuration. Once deleted, go back to Chose PXE Server and select 'Shared Configuration')

7. If step 6 doesn't apply, copy the GUID listed in the first search result and search for that GUID starting from the top of the PXEManager.ini file.

8. The first search result should look similar to below:

[PXEConfig]
PXEServers="Shared","{GUID HERE}"
LastOpenedServer="Shared"
InitDeployLowerLimit=1
InitDeployUpperLimit=254
DelayRangeLowerLimit=1
DelayRangeUpperLimit=10
BootWizExecutablePath="..\Bootwiz\bootwiz.exe"
BootWizSubDirName="BDC"
SequentialBootCount=0
StatusPage=True
PxeSrvBoot="0,0"

9. Delete the GUID HERE entry along with the brackets, comma, and quotes so the entry looks similar to this:

[PXEConfig]
PXEServers="Shared"
LastOpenedServer="Shared"
InitDeployLowerLimit=1
InitDeployUpperLimit=254
DelayRangeLowerLimit=1
DelayRangeUpperLimit=10
BootWizExecutablePath="..\Bootwiz\bootwiz.exe"
BootWizSubDirName="BDC"
SequentialBootCount=0
StatusPage=True
PxeSrvBoot="0,0"

*NOTE: Don't delete any non matching GUIDS

10. Search for the next matching entry for that GUID and the result should look similar to the following:

[PXEServer\{GUID}\BootMenu]
Prompt="Press [F8] to Select a boot option"
AppendServerName=True
Timeout=3
MenuOrder=0,131
BootMenuMap=
Menu=
HasCustom=False

11. Delete this entire section along with the additional sections below that contain the matching GUID:

[PXEServer\{GUID}\Server]
ServerName="RemotePXE"
ServerIPAddr="10.1.1.3"
HasCustom=False

[PXEServer\{GUID}\TFTP]
HasCustom=False

[PXEServer\{GUID}\MACFilter]
HasCustom=False

[PXEServer\{GUID}\DataLogs]
HasCustom=False

[PXEServer\{GUID}\ListeningNICs]
HasCustom=False

12. Once all of these have been removed, save the file and start all of the PXE services. PXE Manager should no longer list that server under "status".

13. If further issues are observed, restore the backup/copy PXEManager.ini and contact support