Advanced Reporting error "Unable to acquire conversation lock after 90 seconds"
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Advanced Reporting error "Unable to acquire conversation lock after 90 seconds"

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Article ID: 142627

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

STEPS TO REPRODUCE: 

1. Login to Clarity and Navigate to Advance Reporting 
2. Click on any one of the Financial Report example (Financial Forecast Review by Plan Grouping)
3. Choose the input value as Fiscal year and Group by Financial Plan 
4. Apply to run the report 

Expected Results: The report should run and show the output 

Actual Results: The report shows the output but there is a an error pop up " Unable to acquire conversation lock after 90 seconds" 

Environment

Release : 15.x

Component : CA PPM SAAS JASPERSOFT

Cause

This property is to set  "lockTimeoutSeconds" property of SessionBindingConversationManager class of spring-webflow.

<property name="lockTimeoutSeconds" value="90"/> 

This timeout is how much time a request can wait to get a lock of resources this waiting happens because previous request of the same user still processing. Until it releases lock current request has to wait for the lock if current request waited for more than given configured value then it throws the exception.

So basically the exception is related to previous request of the same user while not allowing the previous request to complete. 

 


Resolution

Workaround: Reduce the volume of data you are trying to fetch or schedule the report 

Additional Information

See also Financial reports slower/timing out after upgrade due to DE56072