MSP: 'An error occurred while opening CA PPM project' due to wrong bit level
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MSP: 'An error occurred while opening CA PPM project' due to wrong bit level

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Article ID: 133384

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

When attempting to export a project from Clarity to Microsoft project, the following error is thrown:

"An error occurred while opening CA PPM project in Microsoft Project. Please try again."

Environment

Release : All Supported Releases

Component : CA PPM MICROSOFT PROJECT (MSP)

Cause

This may be due to there being a mismatch between the bit version of Microsoft Project and the MSP Interface. To check if this is the cause: 

To check the bit version of Microsoft Project:

  1. Open MSP (open a blank project or any project)
  2. Go to File - Account
  3. Click on the About Project icon (the blue question mark)

At the top of the popup it will specify the bit version: 'Microsoft Project......... bit". Make a note whether this is 32 bit or 64 bit.

To check the bit version of the MSP Interface:

  1. Go to the Start menu
  2. Open the Control Panel - Programs and Features
  3. Find the 'CA PPM Microsoft Project Interface' component on the list of program that comes up.
  • If the component is the 64 bit version it will have x64 in parenthesis after the name (CA PPM Microsoft Project Interface (x64)).
  • If the component is the 32 bit version it will not have anything in parenthesis after the name. 

Resolution

If the bit version of the MSP Interface is different than the bit version of Microsoft Project:

  1. Uninstall the MSP Interface (along with the Schedule Connect and CAClarityAddin).
  2. Then install the components that do match the bit version of Microsoft Project. 

Additional Information

Reference: