Error "IMS1001-File extension .rar is either upload prohibited or it does not match the content type" When Attaching files to xFlow/Service Point ticket
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Error "IMS1001-File extension .rar is either upload prohibited or it does not match the content type" When Attaching files to xFlow/Service Point ticket

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Article ID: 104902

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Catalog CA Service Desk Manager

Issue/Introduction

The following error appears when attaching a file to xFlow/Service Point ticket:

IMS1001-File extension .XXX is either upload prohibited or it does not match the content type application/XXX."

Environment

Service Desk Manager 17.x
xFlow & Service Point 17.x

Cause

There are two possible causes for this error:

1. The file extensions is not allowed in xFlow.

2. The extension does not match the content type of the file.

Resolution

For cause 1:

Add the extension to the allowed list:

1. Log into Service Desk as an Administrator and go to > Administration tab >Flow Analyst Interface > General

2. Open attachments.allowed-content-types > Edit

3. Add the extension and MIME type.

Example: To add .rar files:

.rar:application/x-rar-compressed

Where .rar is the extension and application/x-rar-compressed is the MIME Type.

List of MIME Types can be found in the link below.

For cause 2:

Change the extension to the right one, so it does not fail when verifying the extension.

Additional Information

MIME types

Manage Attachments in xFlow/Service Point

Issue uploading attachments in Service Point