Unable to open probes in IM due to error Cannot create CNimPackageEditor (1)
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Unable to open probes in IM due to error Cannot create CNimPackageEditor (1)

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Article ID: 8878

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM) Unified Infrastructure Management for Mainframe

Issue/Introduction

I have been able to login to the IM we have configured, however when I try to open a probe, such as controller, net_connect, etc, this NimList error is displayed:  Cannot create CNimPackageEditor (1)
 

Environment

- UIM Version: Any
- Infrastructure Manager 4.10

Cause

- Problem with the existing Infrastructure Manager install

- New Infrastructure Manager (IM) install

Resolution

Steps to correct:
  1. Uninstall Nimsoft Infrastructure Manager on the problem machine (via Windows Control Panel, Uninstall Programs)
  2. Uninstall SOAP-runtime-TK3
  3. Reboot the machine
  4. Login with local Administrator rights
  5. Disable any Anti-virus that may be interfering with the installer
  6. Right-click and Run as Administrator to install IM
  7. Test the new installation
IMPORTANT:
The Visual C++ 2008 version of vcredist_x86.exe and vcredist_x64.exe are a requirement!
Installing the other Visual C++ versions (2012, 2017, etc.) will NOT work.

You can obtain and install them at this Microsoft url:  https://www.microsoft.com/en-us/download/details.aspx?id=26368

If you cannot find, cannot download and/or you don't have this package (vs2008_redist_x86-1_00.zip) installed or in your local archive, you can download it from this link:

Additional Information

The IM console needs the vs2008 redistributables installed before running the IM manager install. So you might have to uninstall IM, reboot the machine and then install IM once again.

If you have these packages already downloaded to the Primary hub's local archive you can try to deploy them to the hub/robot where you're trying to install and run the IM client:

If you still get an error or encounter some difficulty, download the packages directly from Microsoft and install them or manually add the vs2008 packages to the hub's local archive folder on the machine, and then restart the distsrv. You may also have to reboot once again.

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