IM install on Windows fails with "Not all ocx/dll files registered properly" error
search cancel

IM install on Windows fails with "Not all ocx/dll files registered properly" error

book

Article ID: 128895

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

  • Infrastructure Manager (IM) installation on Windows fails with "Not all ocx/dll files registered properly" error
  • The files that are not registering are:
    • NimcfgLib.ocx
    • NimPackageEditor.ocx

Environment

  • Any IM release

Cause

  • Infrastructure Manager requires the Visual C++ versions of the vcredist_x86.exe and vcredist_x64.exe to work on any Windows system

Resolution

1. Deploy the following packages to the system where IM is to be installed:

     **vs2008_redist_x86

     **vs2008_redist_x64

2. Uninstall Nimsoft Infrastructure Manager from Windows Programs
3. Uninstall the SOAP-runtime-TK3 from Windows Programs
4. Delete the Nimsoft directory
5. Restart the system
6. Login with local administrator rights
7. Right-click the IM installer binary and choose 'Run as administrator' to install 

Additional Information

Unable to open probes. getting error "Cannot create CNimPackageEditor (1)"