CAHC431I Check detected non-applicable environment RC=08
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CAHC431I Check detected non-applicable environment RC=08

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Article ID: 46162

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Updated On:

Products

COMMON SERVICES FOR Z/OS 90S SERVICES DATABASE MANAGEMENT SOLUTIONS FOR DB2 FOR Z/OS COMMON PRODUCT SERVICES COMPONENT Common Services Datacom/AD Easytrieve Report Generator for Common Services UNICENTER JCLCHECK COMMON COMPONENT CHORUS SOFTWARE MANAGER

Issue/Introduction

We receive the following message when the system is IPL'd and CA Health Checker services are initialized.

CAHC431I Check detected non-applicable environment RC=08 

The same message is generated again if the IBM Health Checker address space (eg. HZSPROC) is stopped and restarted.

Environment

CA Common Services r14.1

z/OS 1.13 and higher

 

Cause

As documented in the CA Common Services Message Guide, this message is informational in nature and is an indication that a CA product health check routine determined that the execution environment is not applicable to the conditions for which the check is designed to examine. The return code presented with the message is what is passed back to the CA Common Health Checker service from the CA product Health Check.

Resolution

To identify what CA Product health check could be responsible for this message, use IBM SDSF CK or CA SYSVIEW HCHECK commands to display the health checks that are defined.

Look for a CA Product health check with a status of "ENV N/A".

Contact the respective CA Product support team and provide them with the name of the health check that you have identified. The support team should be able to help identify why the specific health check is not applicable to the current environment. It may simply be the result of an option defined in the products configuration.

Additional Information

SYSVIEW customers - See KD Article #50233 for more information