Error: "Access Denied. Unable to authenticate the user" after push notification is sent back following Okta SSO integration
search cancel

Error: "Access Denied. Unable to authenticate the user" after push notification is sent back following Okta SSO integration

book

Article ID: 454158

calendar_today

Updated On:

Products

VCF Operations VMware Cloud Foundation

Issue/Introduction

  • /var/log/vmware/vIDB/access-control.log error:

Failed to log in with VCF SSO service. The user did not import or does not belong to any imported group

  • $ALIVE_BASE/user/log/analytics.audit-#########.log error:

Invalid login - message: Cannot complete login due to an incorrect user name or password."

 

Environment

VCF Ops: 9.0.2, 9.1

VCF: 9.0, 9.1

Okta SSO

Cause

  • User and/or user groups need to be imported into VCF Operations after configuring VCF SSO
  • Okta group claims must be tied to the id_token and the Open ID group attribute must be defined as VCF_ADGroupclaim.

Resolution