Unable to Log in to VCF Operations UI Using VCF SSO with Error: “Failed to login with VCF SSO service. The user did not import or does not belong to any imported group.”
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Unable to Log in to VCF Operations UI Using VCF SSO with Error: “Failed to login with VCF SSO service. The user did not import or does not belong to any imported group.”

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Article ID: 438657

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Updated On:

Products

VCF Operations

Issue/Introduction

User is unable to log in to the VCF Operations UI using VCF SSO. The login attempt fails with the following error:
“Failed to login with VCF SSO service. The user did not import or does not belong to any imported group.”

Environment

  • VCF Operations 9.x.x

Cause

The issue occurs because no user or user groups have been imported into VCF Operations after configuring VCF SSO.

Resolution

To resolve the issue, import the required user or user groups into VCF Operations. Please follow the steps mentioned below:
  1. Log in to VCF Operations as a local admin: ( https://<VCF_OPS_FQDN_OR_IP>/ui )
  2. Navigate to: Administration > Control Panel > Access Control

  3. Go to the User or User Groups tab.
  4. Click the horizontal ellipsis (⋯) next to the Add button and select: Import from Source

  5. In the Import page, set the Import From field to: VCF SSO
  6. Use the Search Prefix field to find users or groups, then click Next and Save.
  7. After the users and/or groups appear in the Access Control list, select the entry.
  8. Click the vertical ellipsis (⋮) and choose Edit.
  9. Under Assign Roles and Scope, assign the appropriate roles and scopes.
  10. Click Save.

Additional Information