Error 400 Bad Request when exporting reports with large number of records
search cancel

Error 400 Bad Request when exporting reports with large number of records

book

Article ID: 454089

calendar_today

Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

When attempting to export reports to PDF in Service Desk Manager (SDM) 17.5 Native Analytics, the export fails, hangs, or returns a "400 Bad Request" error.

This issue occurs when the report contains a large number of records (e.g., >11,000).

NX_ROOT\log\reportMS.log shows the following error:

java.util.concurrent.CompletionException: com.ca.casm.exception.CasmBaseException: ReceiveTimeout

Environment

Service Desk Manager 17.5

Component: Native Analytics

Cause

Large datasets may exceed the default execution timeout (60 seconds), resulting in an internal error or process termination.

Resolution

1. Navigate to the following directory on the SDM server where Native Analytics is deployed: [NX_ROOT]\bopcfg\www\CATALINA_BASE_RPT\webapps\CASMReports\WEB-INF\classes

2. Take a backup of the application.conf and move to folder outside the NX_ROOT

3. Open the application.conf file in a text editor.

4. Locate the maxTimeout parameter under generic.api and increase the value (e.g., from 60 to 120) to a number that allows to fetch all the data being exported.

5. Restart the SDM reporting services to apply the configuration changes with the following commands in cmd:

pdm_tomcat_nxd -c STOP -t RPT

pdm_tomcat_nxd -c START -t RPT

Additional Information

Turning on logging for Native Analytics