"Error: Unable to login because you do not have permission on any vCenter Server systems connected to this client".
search cancel

"Error: Unable to login because you do not have permission on any vCenter Server systems connected to this client".

book

Article ID: 453270

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • When attempting to log in to the vCenter Server, the login fails with the error message: "Unable to login because you do not have permission on any vCenter Server systems connected to this client."



  • User is successfully authenticated via Active Directory.

  • Login process completes on the vCenter server UI but immediately displays a permission-related error.

  • The vCenter Server is joined to the domain, but specific AD groups or users are unable to access the environment.

  • Missing AD group permission on the vCenterserver level or global permissions.

Environment

vCenter Server

Cause

This issue typically occurs when the Active Directory group or user account has not been explicitly granted the necessary permissions within the vCenter Server.

Resolution

To resolve this issue add the necessary permissions to the Active Directory users on the vCenter server level by logging in as a user with administrative privileges.

Managing Permissions for vCenter Server Components

Additional Information

If the issue persists, use the domainjoin-cli utility to verify that the vCenter Server is still actively joined to the domain and that there are no communication issues with the domain controllers.

Login to the vCenter server SSH as root user to validate the same:

/opt/likewise/bin/domainjoin-cli query

Contact Broadcom support if the issue still persists.