The Data Services Manager (DSM) connector in VMware Cloud Foundation Automation remains in a "Pending" state, preventing the connection from being established. Attempts to remove or re-add the connector fail, and attempts to uninstall the DSM service via the portal or API return a "403 Forbidden" error.
This issue occurs because the user account performing the DSM service operations (install, uninstall, or manage) is assigned a custom role, such as a cloned "admin" role. The DSM service requires privileges that are only available to the built-in "System Administrator" role.
To resolve this issue, you must perform service operations using an account with the built-in "System Administrator" role.
If you require further assistance after verifying the role permissions, contact Broadcom Support. Subscribe to a Broadcom knowledge article by article or product to get updates on this issue.