"Remediate for appliance <FQDN> has failed. Failed to perform specified operation on SDDC manager"less /var/log/vmware/vcf/operationsmanager/operationsmanager.log:YYYY-MM-DDTHH:MM:SSZ ERROR [vcf_om,0000000000000000,0000] [c.v.v.p.r.DiagnosticMessageProcessor,Thread-134] Pre validation of password REMEDIATE has failed, error : Resources : [FQDN]are not in ACTIVE stateYYYY-MM-DDTHH:MM:SSZ ERROR [vcf_om,0000000000000000,0000] [c.v.v.p.r.NewPasswordTransactionHandler,Thread-134] REMEDIATE operation with id : 1XX failed !VCF 9.x
This issue occurs because the status of the NSX-T Manager is incorrectly recorded as an ERROR state in the SDDC Manager's platform database.
psql -h localhost -U postgres -d platform -c "select id, status, cluster_fqdn from nsxt where status!='ACTIVE';"psql -h localhost -U postgres -d platform -c "update nsxt set status='ACTIVE' where id='<id>';"Note: Ensure to take snapshot of the SDDC Manager VM before proceeding with database modifications.
Contact Broadcom Technical Support for further assistance or queries using Contact Broadcom Support