Firewall rule logs missing in VMware Cloud Director due to Aria Operations for Logs license error
search cancel

Firewall rule logs missing in VMware Cloud Director due to Aria Operations for Logs license error

book

Article ID: 453005

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

When attempting to view firewall logs in the VMware Cloud Director (VCD) UI, the following error is displayed: [ ####-###-###-###-######### ] class com.vmware.vcloud.common.network.LogInsightApiException. This error typically indicates that the connection to the log provider is failing due to an licensing issue.

  • LogInsightApiException displayed in VCD UI when viewing firewall logs.
  • System banner in Aria Operations for Logs UI: "You are not using a valid Operations for Logs license."

Environment

VMware Cloud Director 10.6.x
VMware Aria Operations for Logs 8.18.x

Cause

The issue is caused by a missing or invalid license in Aria Operations for Logs.

Resolution

Follow the below steps to resolve this issue.

  1. Log in to the VMware Aria Operations for Logs UI.
  2. Check for a banner at the top of the interface stating: "You are not using a valid Operations for Logs license."
  3. Obtain a valid evaluation or permanent license key from the product download page.
  4. Navigate to Management > Licenses in the Aria Operations for Logs UI.
  5. Apply the valid license.
  6. Once the license is applied, verify that firewall logs are propagating by checking the VCD UI again.

 

Additional Information