スナップショット操作が error code: 3 - Quiesce operation canceled で失敗する
search cancel

スナップショット操作が error code: 3 - Quiesce operation canceled で失敗する

book

Article ID: 452069

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

免責事項:これは英文の記事「Snapshot Operation fail with error code: 3 - Quiesce operation canceled.」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。


静止スナップショットの作成時に仮想マシンのバックアップ操作 (Commvault や Avamar を使用しているもの等) が失敗します。vCenter はゲストオペレーティングシステムの静止の失敗を報告します。

症状:

  • バックアップが error code 10052 で失敗します。
  • vCenter に「仮想マシンの静止中にエラーが発生しました。」と表示されます。
  • ログファイル/var/run/log/hostd.logThe error code was: 3 The error message was: Quiesce operation canceledが含まれます。

Environment

  • vCenter Server 7.x / 8.x
  • Windows ゲストオペレーティングシステム

Cause

この事象は、ゲスト OS 内の Microsoft ボリュームシャドウコピーサービス (VSS) にが原因で発生します。これは通常、次のような場合に発生します。

  • VSS サービスが停止しています。
  • 1 つ以上の VSS ライターが "Failed"、あるいは "Unstable" 状態です。
  • Microsoft サービスコントロールマネージャーが操作を中断します。

Resolution

VSS の機能を検証および復元するには、下記の手順を実施します。

  1. Windows ゲスト OS に管理者としてログインします。
  2. コマンドプロンプトを開き、次のコマンドを実行します。vssadmin list writers
  3. state が [1] Stable 以外のライターを出力から確認します。ライターが failed な場合、対応するサービスあるいは VM を再起動します。
  4. Win + R を押し、services.msc と入力して Enter を押下します。
  5. Volume Shadow Copy サービスを見つけます。
  6. そのサービスを右クリックしてプロパティを選択し、スタートアップの種類自動に設定します。
  7. もしもサービスが停止している場合は、開始をクリックします。
  8. VMware Tools サービスを再起動します。
  9. スナップショット、あるいはバックアップ操作を再度実行します。

問題が解決しない場合は、VMware Tools を最新バージョンへアップデートください。参照:Download Broadcom products, patches and software

Additional Information

VSS アーキテクチャの詳細情報については、Microsoft の資料を参照してください。

How Volume Shadow Copy Service Works