Snapshot Operation fail with error code: 3 - Quiesce operation canceled.
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Snapshot Operation fail with error code: 3 - Quiesce operation canceled.

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Article ID: 419700

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Accessed the Avamar Console and confirmed that the VM backup is consistently failing with error code 10052.

Verified from vCenter that the snapshot operation failed with the following error:

Error : An error occurred while quiescing the virtual machine. 

Log file /var/run/log/hostd.log will show entries similar to:

YYYY-MM-DDTHH:MM:SS Db(167) Hostd: --> The error code was: 3
YYYY-MM-DDTHH:MM:SS Db(167) Hostd: --> The error message was: Quiesce operation canceled
YYYY-MM-DDTHH:MM:SS In(166) Hostd: [Originator@6876 sub=Vimsvc.ha-eventmgr] Event 111835 : Warning message on VM on ESXi in datacenter: The guest OS has reported an error during quiescing. The error code was: 3 The error message was: Quiesce operation canceled

Environment

vCenter Server 7.x

vCenter Server 8.x

Cause

  • Volume Shadow Copy Service fails within the guest OS.
  • Some VSS writers were intermittently going down, leading to the failure. Windows VSS writers (such as SQL, Exchange, or System Writer) malfunction.
  • The error (The error code was: 3) are generated by the Microsoft Service Control Manager.

Resolution

  • Started the VSS Writer and Volume shadow copy services.
  • During the troubleshooting session, VSS writers, VMware Tools, and services were verified to be running normally before taking a new snapshot. The snapshot completed successfully afterward.

Steps on how to check the  VSS writers :

  1. Open Command Prompt or PowerShell as an administrator. (In Windows, search for "Command Prompt" or "PowerShell," right-click the result, and select "Run as administrator".)
  2. Type the command: vssadmin list writers.
  3. Press Enter to execute the command. 
FYI - What the output shows ?
 
The command output provides a list of all VSS writers on the system, their state (e.g., stable, failed), and other relevant information. This is a critical first step for troubleshooting any VSS-related issues, especially with backup operations. 

Steps on how to  check the service status  : 

  1. Press Win + R, type services.msc, and press Enter.
  2. Scroll down and find "Volume Shadow Copy".
  3. Check its status; if stopped, right-click and select Start.
  4. Right-click, select Properties, and ensure Startup type is set to Automatic. 

 

Additional Information

For more information, please refer to the following Microsoft article:

How Volume Shadow Copy Service Works