Mounting an ISO file on a virtual machine with an attached RDM disk fails with the error "Permission 'Datastore: [System > Read]' is missing"
search cancel

Mounting an ISO file on a virtual machine with an attached RDM disk fails with the error "Permission 'Datastore: [System > Read]' is missing"

book

Article ID: 452061

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

When a user with restricted permissions attempts to mount a "Datastore ISO file" to a virtual machine's CD/DVD drive, the task fails with the following error:

Permission to perform this operation was denied.
You do not hold privileges "datastore <Datastore Name> : [System > Read]"

Environment

vCenter Server

Cause

If an RDM disk is attached to the virtual machine, this issue is caused by a lack of read permissions on the datastore where the RDM disk is located.

Resolution

Grant read permissions to the datastore where the RDM disk is located.

[Procedure for Granting Read Permissions]

  1. Log in to the vSphere Client.
  2. Select the Datastore tab > Permissions > Add.
  3. Select the desired user or group, and assign the "Read-only" role.
    * "Propagate to children" is not required.

Additional Information

Japanese KB: RDMディスクが接続された仮想マシンでISOファイルをマウントすると「権限『データストア: [システム > 読み取り]』がありません」エラーで失敗する