When a user with restricted permissions attempts to mount a "Datastore ISO file" to a virtual machine's CD/DVD drive, the task fails with the following error:
Permission to perform this operation was denied.You do not hold privileges "datastore <Datastore Name> : [System > Read]"
vCenter Server
If an RDM disk is attached to the virtual machine, this issue is caused by a lack of read permissions on the datastore where the RDM disk is located.
Grant read permissions to the datastore where the RDM disk is located.
[Procedure for Granting Read Permissions]