RDMディスクが接続された仮想マシンでISOファイルをマウントすると「権限『データストア: [システム > 読み取り]』がありません」エラーで失敗する
search cancel

RDMディスクが接続された仮想マシンでISOファイルをマウントすると「権限『データストア: [システム > 読み取り]』がありません」エラーで失敗する

book

Article ID: 452060

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

免責事項:これは英文の記事「Mounting an ISO file on a virtual machine with an attached RDM disk fails with the error "Permission 'Datastore: [System > Read]' is missing"」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

一部の制限された権限を持つユーザーが、仮想マシンのCD/DVDドライブに「データストア ISO ファイル」をマウントしようとする際に、以下のエラーが発生してタスクが失敗します。

設定の編集 に失敗しました。
この操作を実行する権限が拒否されました。
権限『データストア <データストア名> : [システム > 読み取り]』がありません

Environment

vCenter Server

Cause

仮想マシンにRDMディスクが接続されている場合、RDMディスクが配置されているデータストアへの読み取り権限がないことが原因です。

Resolution

RDMディスクが配置されているデータストアへの読み取り権限も付与します。

[読み取り権限付与手順]

  1. vSphere Clientにログインします。
  2. データストアタブを選択 > 権限 > 追加を選択します。
  3. ユーザー/グループに任意のユーザー/グループを選択し、ロールに"読み取り専用"を付与します。
    ※"子へ伝達"は必須ではありません。