vSphere Client を使用した OVF テンプレートからの仮想アプライアンスのデプロイに失敗する
search cancel

vSphere Client を使用した OVF テンプレートからの仮想アプライアンスのデプロイに失敗する

book

Article ID: 451501

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

免責事項: これは英文の記事「Unable to deploy virtual appliance from OVF template via vSphere Client」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

  • vSphere Client UI を使用した OVF のデプロイが失敗し、次のエラーメッセージが表示されます。

OVF パッケージのデプロイに失敗しました。原因: 一般的なシステム エラーが発生しました: マニフェストまたは証明書ファイルを取得できません。

  • content-library サービスのログ (/var/log/vmware/content-library/cls.log) を確認すると、次のエラーが記録されています。
    YYYY-MM-DDThh:mm:ss.###+hh:mm | ERROR    | ########-########-auto-######-h5:########-##-## | cls-simple-activity-1     | ImportSessionActivity          | OVF import session ########-####-####-####-############ failed with server error.
    com.vmware.vapi.std.errors.ServiceUnavailable: ServiceUnavailable (com.vmware.vapi.std.errors.service_unavailable) => {
        messages = [LocalizableMessage (com.vmware.vapi.std.localizable_message) => {
        id = com.vmware.ovfs.ovfs-main.ovfs.transfer_failed_mf_cert_retrieval_timeout,
        defaultMessage = Unable to retrieve manifest or certificate file.,
        args = [],
        params = <null>,
        localized = <null>
    }],
        data = <null>,
        errorType = SERVICE_UNAVAILABLE

Environment

VMware vCenter Server 8.0.x

Cause

この問題は、OVF にサイズの大きいディスクファイルが含まれている場合に発生する可能性があります。

コンテンツライブラリがディスクの後に OVF のマニフェストファイル (.mf) を読み取ろうとすることがあり、この時点で、事前設定されたファイル転送のタイムアウト値をすでに超過している場合があります。

Resolution

オプション A - 転送スレッドプールサイズを増加させる:

  • vi エディタを使用して /etc/vmware-content-library/config/ts-config.properties を編集します。
  • 次の行を検索します。
    transfer.threads.poolSize=20
  • 値を 40 などに変更します。
  • 変更を保存してエディタを終了します。
  • content-library サービスを再起動します。
    # service-control --restart vmware-content-library
    

 

オプション B - コンテンツライブラリの転送セッションのタイムアウト値を延長する:

  • vi エディタを使用して /etc/vmware-content-library/config/ts-config.properties を編集します。
  • 次の行を検索します。
    transfer.http.request.timeout.seconds=120
    transfer.nfcClient.socket.timeout.seconds=120
  • 値を 240 などに変更します。
  • 変更を保存してエディタを終了します。
  • content-library サービスを再起動します。
    # service-control --restart vmware-content-library

 

Additional Information

transfer.threads.poolSize は、転送用のネットワーク接続プールのサイズに対応します。
transfer.nfcClient.socket.timeout.seconds および transfer.http.request.timeout.seconds は、それぞれ NFC ソケットと HTTP リクエストがタイムアウトするまでの秒数に対応します。