免責事項: これは英文の記事「Unable to deploy virtual appliance from OVF template via vSphere Client」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。
OVF パッケージのデプロイに失敗しました。原因: 一般的なシステム エラーが発生しました: マニフェストまたは証明書ファイルを取得できません。
/var/log/vmware/content-library/cls.log) を確認すると、次のエラーが記録されています。YYYY-MM-DDThh:mm:ss.###+hh:mm | ERROR | ########-########-auto-######-h5:########-##-## | cls-simple-activity-1 | ImportSessionActivity | OVF import session ########-####-####-####-############ failed with server error.
com.vmware.vapi.std.errors.ServiceUnavailable: ServiceUnavailable (com.vmware.vapi.std.errors.service_unavailable) => {
messages = [LocalizableMessage (com.vmware.vapi.std.localizable_message) => {
id = com.vmware.ovfs.ovfs-main.ovfs.transfer_failed_mf_cert_retrieval_timeout,
defaultMessage = Unable to retrieve manifest or certificate file.,
args = [],
params = <null>,
localized = <null>
}],
data = <null>,
errorType = SERVICE_UNAVAILABLEVMware vCenter Server 8.0.x
この問題は、OVF にサイズの大きいディスクファイルが含まれている場合に発生する可能性があります。
コンテンツライブラリがディスクの後に OVF のマニフェストファイル (.mf) を読み取ろうとすることがあり、この時点で、事前設定されたファイル転送のタイムアウト値をすでに超過している場合があります。
/etc/vmware-content-library/config/ts-config.properties を編集します。transfer.threads.poolSize=20# service-control --restart vmware-content-library
/etc/vmware-content-library/config/ts-config.properties を編集します。transfer.http.request.timeout.seconds=120
transfer.nfcClient.socket.timeout.seconds=120# service-control --restart vmware-content-library
transfer.threads.poolSize は、転送用のネットワーク接続プールのサイズに対応します。
transfer.nfcClient.socket.timeout.seconds および transfer.http.request.timeout.seconds は、それぞれ NFC ソケットと HTTP リクエストがタイムアウトするまでの秒数に対応します。