"Unable to retrieve manifest or certificate file" when deploying a virtual appliance from OVF template" - vSphere.
search cancel

"Unable to retrieve manifest or certificate file" when deploying a virtual appliance from OVF template" - vSphere.

book

Article ID: 425836

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • OVF deployment using the vSphere Client UI fails with an error message:
    Failed to deploy OVF package. Cause: A general system error occurred: Unable to retrieve manifest or certificate file.
  • When reviewing the content library service log, /var/log/vmware/content-library/cls.log, the following error can be seen:
    <time_stamp> | ERROR    | ########-########-auto-######-h5:########-##-## | cls-simple-activity-1     | ImportSessionActivity          | OVF import session ########-####-####-####-cccd84d2ca41 failed with server error.
    com.vmware.vapi.std.errors.ServiceUnavailable: ServiceUnavailable (com.vmware.vapi.std.errors.service_unavailable) => {
    messages = [LocalizableMessage (com.vmware.vapi.std.localizable_message) => {
    id = com.vmware.ovfs.ovfs-main.ovfs.transfer_failed_mf_cert_retrieval_timeout,
    defaultMessage = Unable to retrieve manifest or certificate file.,
    args = [],
    params = <null>,
    localized = <null>
    }],
    data = <null>,
    errorType = SERVICE_UNAVAILABLE

Environment

  • VMware Cloud Foundation (VCF)
  • VMware vSphere Foundation (VVF)
  • VMware vCenter Server 7.0.x / 8.0.x
  • VMware vCenter 9.x

Cause

This issue has been observed when the OVF contains one or more large disk files.
In some cases the content library tries to read the manifest file (*.mf) of the OVF after the disk(s), at which point the preconfigured timeout for file transfers might have already expired.

Resolution

Note:Before making any changes to the configuration in the vCenter Server Appliance, make sure to create a fresh backup of snapshot of the VCSA. If the VCSA is part of an Enhanced Linked Mode (ELM) replication setup, offline snapshots of all ELM nodes are required. See VMware vCenter in Enhanced Linked Mode pre-changes snapshot (online or offline) best practice for more information.
      

To solve this issue, implement either of the following to options:

Option A - increase the transfer thread pool size:

  1. Edit /etc/vmware-content-library/config/ts-config.properties using the VI editor
  2. Find the following line:
    transfer.threads.poolSize=20
  3. Change the value, e,g. to 40
  4. Save and exit the editor (:wq!).
  5. Restart the content-library service:
    # service-control --restart vmware-content-library

Option B - increase the transfer session timeout for the content library:

  1. Edit /etc/vmware-content-library/config/ts-config.properties using the VI editor.
  2. Find the following lines:
    transfer.http.request.timeout.seconds=120
    transfer.nfcClient.socket.timeout.seconds=120
  3. Change the value for both line, e,g. to 240
  4. Save and exit the editor (:wq!).
  5. Restart the content-library service:
    # service-control --restart vmware-content-library

Additional Information

transfer.threads.poolSize corresponds to the size of the network connection pools for transfers.
transfer.nfcClient.socket.timeout.seconds and transfer.http.request.timeout.seconds correspond to the number of seconds before nfc sockets and http requests are timed out, respectively.