Scheduled Banner jobs fail intermittently with SQLState 08000 (No more data to read from socket) when jobs run concurrently or after periods of inactivity. This issue occurs when the network device or database listener terminates the connection due to an idle timeout setting, causing the Banner Agent Job to abort due to connectivity loss.
Symptoms:
ErrorCode 17410 (SQLState 08000).The error 17410 indicates the socket connection between the Banner Agent and the database has been closed by the network infrastructure (e.g., firewall or network idle timeout).
Workaround:
Schedule a "dummy" or low-impact Banner job to run on an interval shorter than the firewall/network/timeout window or shortly before period of inactivity ends.
If the issue persists after reviewing network settings, please for further investigation.