Error: "Only Disk's profile is being changed but it's datastore or host is not being changed during relocate" when changing storage policy on a VM
search cancel

Error: "Only Disk's profile is being changed but it's datastore or host is not being changed during relocate" when changing storage policy on a VM

book

Article ID: 451201

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • Attempting to change a Virtual Machine (VM) storage policy (e.g., from Premium to Standard) via the General > Edit page in the VMware Cloud Director (VCD) Tenant UI fails.
  • The VCD task console displays the following error: Unable to relocate VM. - Task failed, vc-id={####}, error={A specified parameter was not correct: relocateSpec.diskLocator.profile}
  • vCenter Server vpxd.log shows the following message: Only Disk's profile is being changed but it's datastore or host is not being changed during relocate, so use reconfig instead

Environment

VMware Cloud Director 10.6.1.x

Cause

This issue occurs because changing the storage policy via the VM's General settings page causes Cloud Director to invoke a RelocateVM specification in vCenter. vCenter rejects this call if only the profile is changing without a change to the datastore or host.

Resolution

To resolve this issue, perform the storage policy change at the individual disk level:

  1. Log in to the VMware Cloud Director Tenant UI.
  2. Navigate to the affected virtual machine.
  3. Click Hardware and select Hard Disks.
  4. Update the Storage Policy for the VM Home and each individual hard disk.
  5. Click Save.

Additional Information