Unable to relocate VM. - Task failed, vc-id={####}, error={A specified parameter was not correct: relocateSpec.diskLocator.profile}vpxd.log shows the following message: Only Disk's profile is being changed but it's datastore or host is not being changed during relocate, so use reconfig insteadVMware Cloud Director 10.6.1.x
This issue occurs because changing the storage policy via the VM's General settings page causes Cloud Director to invoke a RelocateVM specification in vCenter. vCenter rejects this call if only the profile is changing without a change to the datastore or host.
To resolve this issue, perform the storage policy change at the individual disk level: