Troubleshooting VCF Instance Creation Failure Due to Capital Letters in SAN Hostnames
search cancel

Troubleshooting VCF Instance Creation Failure Due to Capital Letters in SAN Hostnames

book

Article ID: 451116

calendar_today

Updated On:

Products

VMware SDDC Manager / VCF Installer

Issue/Introduction

VCF instance creation fails when configuring Single Sign-On (SSO) on a standalone vCenter instance. During deployment, the VMSP component configure VIDB task fails with an error indicating inability to register with VCF Operations.

    • Deployment failure during VMSP VIDB task.
    • Error indicating registration failure with VCF Operations.

Environment

VCF Operations 9.1

Cause

The VCF Operations certificate Subject Alternative Name (SAN) field hostname contains capital letters. FQDN and IP address specifications for VCF instances require hostnames to be defined without capital letters.

Resolution

  1. Modify the deployment Workflow JSON file.
  2. Rename all capital letters in the VCF Operations FQDN to lowercase.
  3. Publish the updated Workflow JSON file.
  4. Resume the deployment.

Additional Information

Reference: Broadcom TechDocs requirements for VCF instance FQDN and IP address specifications (first-vcf-instance-fqdns-and-ip-addresses). For log retrieval instructions, see the relevant product documentation. To speak with a customer representative or a Support Engineer see Contact Broadcom Support.