When attempting to patch vCenter Server 8.x, the process fails at 90% because the vc-ws1a-broker service fails to start. This issue occurs after running the vCenter 9 RDU upgrade precheck if the upgrade process is not completed.
In /var/log/vmware/vmon/vmon.log
<vc-ws1a-broker> Service pre-start command's stderr: raise Exception('Command failed: stdout %r stderr %r' % (text, err))level=error msg="runc run failed: unable to start container process: error during container init: error setting cgroup config for procHooks process: bpf_prog_query(BPF_CGROUP_DEVICE) failed: invalid argument" <vc-ws1a-broker> Service pre-start command failed with exit code 1.<vc-ws1a-broker> Service pre-start command failed with exit code 1
After running the vCenter 9 RDU upgrade precheck and not moving forward with the upgrade for any reason when rebooting the vCenter 8 appliance, the Workspace ONE broker service will fail to start.
The 9.1 precheck script modifies the vCenter 8 container cgroup configuration in the /boot/systemd.cfg file, enabling a unified cgroup hierarchy that is incompatible with the vCenter 8.x container runtime.
Revert the cgroup configuration to legacy mode:
/boot/systemd.cfg file systemd.unified_cgroup_hierarchy=yes to systemd.legacy_systemd_cgroup_controller=yesvc-ws1a-broker are running using the command: service-control --status --allFor further assistance, contact Broadcom Support