Bootstrap ESX Host Loses NFS Datastore Connectivity During VCF Deployment
search cancel

Bootstrap ESX Host Loses NFS Datastore Connectivity During VCF Deployment

book

Article ID: 450619

calendar_today

Updated On:

Products

VMware SDDC Manager / VCF Installer

Issue/Introduction

  • During VMware Cloud Foundation (VCF) deployment, the bootstrap ESX host loses connectivity to the NFS datastore causing the deployment to fail.

Environment

VMware Cloud Foundation (VCF) 9.x

Cause

This issue occurs when the NFS VMkernel interface (vmknic) or portgroup on the bootstrap ESX host is pre-configured with a name that does not match the portgroup name specified in the VCF installer input network specification.

When a mismatch occurs, the VCF Installer workflow ignores the pre-existing, misnamed VMkernel interface and attempts to create a new one. This results in:

  • Multiple VMkernel interfaces being configured for NFS on the same ESX host.
  • The VCF Installer workflow migrating or attempting to manage interfaces that were not created by the installer, leading to connectivity loss to the datastore.
  • Deployment workflow failures during later stages when the installer expects specific network configurations.

To avoid this, On bootstrap ESX host always pre-create the port group and vmknic strictly according to the NFS input network specification provided for the deployment.

Resolution

  1. Reimage the hosts.
  2. Create the NFS portgroup using the same name provided in the input specification for the VCF installer.
  3. Create the NFS vmknic under that same portgroup using an IP address from the network pool range.
  4. Restart the VCF installer workflow.

Additional Information