VCF Installer fails on "Configure NSX Backup Schedule" stage with error "Failed to configure NSX Backup Schedule for NSX Managers"
search cancel

VCF Installer fails on "Configure NSX Backup Schedule" stage with error "Failed to configure NSX Backup Schedule for NSX Managers"

book

Article ID: 450474

calendar_today

Updated On:

Products

VMware SDDC Manager / VCF Installer

Issue/Introduction

  • In the VCF Installer UI, the task "Configure NSX Backup Schedule" fails with error "Failed to configure NSX Backup Schedule for NSX Managers" 
  • In the domainmanager.log the following errors are seen: 
    CONFIGURE_BACKUP_SCHEDULE_TASK_FAILED Error while configuring backup schedule for NSX Managers
    com.vmware.evo.sddc.orchestrator.exceptions.OrchTaskException: Error while configuring backup schedule for NSX Managers
    Caused by: com.vmware.vapi.std.errors.InvalidRequest: InvalidRequest (com.vmware.vapi.std.errors.invalid_request) (statusCode:400) => {
        messages = [],
        data =  => {error_message=passphrase is too weak. It must be at least 8 characters long and contain at least one each: lowercase, uppercase, numeric character and special character., httpStatus=BAD_REQUEST, error_code=29324, module_name=backup-restore},
        errorType = INVALID_REQUEST

Environment

VMware Cloud Foundation 9.x

Cause

The backup user account does not meet the password requirements per Default Password Requirements for VCF Components

Resolution

  1. Login to the SDDC Manager VM/ VCF Installer as the vcf user and elevate to root with the su command
  2. Run the following command to check the current backup account password to see if it meets the requirements: 
    lookup_passwords
  3. If the password does not meet the requirements, change the password in the workflow.json to meet the requirements. 
    1. Retrieve the latest deployment ID with KB: Auto generated password retrieval from VCF Installer 9.1 appliance
    2. Edit the workflow.json with a new password with KB and push the new json: Retry SDDC Manager workflows by modifying workflow spec files
    3. Lastly confirm the backup account is not disconnected and perform a remediate to have SDDC Manager update the new backup account password : Remediate Passwords
    4. Confirm with the lookup_passwords command that the new backup account meets the requirements. 
  4. Retry the VCF Deployment. 

Additional Information

Similar KB: