SDDC Manager UI or API reports the following error: DAYN_GUARDRAILS_VALIDATION_FAILED: DELETE_DOMAIN operation validation failed/var/log/vmware/vcf/operationsmanager/operationsmanager.year-month-day.#.log/var/log/vmware/vcf/lcm/lcm.year-month-day.#.log-debug/var/log/vmware/vcf/domainmanager/domainmanager.year-month-day.#.logjava.net.UnknownHostException: <VC-FQDN>: Name or service not knownVMware Cloud Foundation 9.0.2
SDDC Manager 9.0.2
SDDC Manager appliance (without memory) before proceeding with troubleshooting. Taking and restoring snapshots of the SDDC Manager applianceSDDC Manager appliance can successfully resolve the vCenter FQDN. Run the following commands from the SDDC Manager SSH console:getent hosts <add-correct FQDN-from-VC>
nslookup <add-correct FQDN-from-VC>If resolution fails or returns an incorrect IP:nslookup returns the valid IP from the SDDC Manager.SDDC Manager UI.Inventory > Workload Domains.SDDC Manager inventory. Go to SDDC Manager UI > Inventory > Workload Domains.Establish an SSH session to the SDDC Manager appliance using the vcf user account.
Escalate privileges to root by issuing the su root command and supplying the appropriate credentials.
Initiate the standard health check by executing the following command:
sudo /opt/vmware/sddc-support/sos --health-check