免責事項:これは英文の記事「Unable to unmount the NFS datastore used as the syslog output destination」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。
この記事では、以下の条件下でsyslog出力先として使用されていたNFSデータストアをアンマウントできない問題について説明します。
・NFSデータストアXをsyslog出力先として指定、その後別のNFSデータストアYに出力先を変更します。
syslog出力先を変更するには、vSphere ClientでESXiホストを選択し、構成 > システムの詳細設定にあるSyslog.global.logDirで指定します。
この場合、NFSデータストアXをアンマウントすると、以下エラーが発生します。
ホストの構成中にエラーが発生しました: 。操作に失敗しました。診断レポート: Unable to complete Sysinfo operation. Please see the VMkernel log file for more details.: Busy: VSI node (5007:)
エラー発生時に表示される画面を以下に示します。
VMware ESXi 8.0
clusterAgent プロセスが 出力先の変更前のNFS データストア上のファイルを開いていることが原因です。
lsof
###### clusterAgent FILE 2 /vmfs/volumes/12345678-9abcdefg/clusterAgent.stderr
回避策は以下の通りです。
1. SSH経由でESXiホストに接続します。
2. 以下のコマンドを実行して、clusterAgentを再起動します。
/etc/init.d/clusterAgent restart