This article describes an issue where an NFS datastore used as a syslog output destination cannot be unmounted under the following conditions.
・ Specify NFS datastore X as the syslog output destination, then change the output destination to another NFS datastore Y.
To change the syslog output destination, select the ESXi host in the vSphere Client and specify the location in Syslog.global.logDir, found under Configure > Advanced System Settings.
In this case, unmounting NFS datastore X results in the following error.
An error occurred during host configuration: . Operation failed, diagnostics report: Unable to complete Sysinfo operation. Please see the VMkernel log file for more details.: Busy: VSI node (5007:)
The screen displayed when the error occurs is shown below.
VMware ESXi 8.0
The cause is that the clusterAgent process has a file open on the NFS datastore prior to the change of the output destination.
lsof
###### clusterAgent FILE 2 /vmfs/volumes/12345678-9abcdefg/clusterAgent.stderr
The workaround is as follows.
1. Connect to the ESXi host via SSH.
2. Run the following command to restart clusterAgent.
/etc/init.d/clusterAgent restart
Japanese Version : syslog 出力先として使用されていたNFS データストアをアンマウントできません