"Unable to get the dvs name: Status(bad0007)= Bad parameter" during vDS removal from a Host
search cancel

"Unable to get the dvs name: Status(bad0007)= Bad parameter" during vDS removal from a Host

book

Article ID: 449786

calendar_today

Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

When attempting to remove a VMware vSphere ESXi host from a vSphere Distributed Switch (vDS) via the VMware vCenter Server UI, the operation fails.

The following error is observed in the UI: "An error occurred during host configuration: Operation failed, diagnostics report: Unable to get the dvs name: Status(bad0007)= Bad parameter."

Environment

VMware vCenter Server 9.0.1.0
VMware vSphere ESXi 9.0.1.0
vSphere Distributed Switch 9.0.0

Cause

The ESXi host contains a corrupted or orphaned vDS configuration within its local database (dvsdata.db). This prevents vCenter Server from properly managing the host's network state.

Resolution

If you believe you have encountered this issue, please open a support case with Broadcom Support and refer to this KB article.

For more information, see  Creating and managing Broadcom support cases

Additional Information

See also:

Adding a host to vDS Distributed Switch fails with error: Create DVSwitch failed with the following error message: Unable to Create Proxy DVS ; Status(bad0005)= Already exis