VCF Installer Brownfield Import Fails at Stage "Join the Operation Existing Appliance Stage"
search cancel

VCF Installer Brownfield Import Fails at Stage "Join the Operation Existing Appliance Stage"

book

Article ID: 448972

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite) VCF Operations

Issue/Introduction

  • During a VMware Cloud Foundation (VCF) BrownField Import, the VCF Installer workflow fails at stage 3 (Cloud Proxy deployment failure) during the "Join the Operation Existing Appliance" stage.
  • The following error is reported in the installer log:
 ERROR [c.v.e.s.o.model.error.ErrorFactory, dm-exec-6044] [LG76PD] FLEET_ADD_CLOUD_PROXY_NODE_INPUT_PREPARATION_FAILED Input preparation for adding VCF Cloud Proxy node to existing VCF Operations has failed

Environment

  • VMware Cloud Foundation 9.1.x
  • VCF Operations 9.1.x

Cause

Fleet LCM discovery of the VCF Operations component requires an FQDN, but the Operations CASA registration for the master node incorrectly returns its IP address since Fleet's discovery of the VCF Operations component requires an FQDN, it fails.

Resolution

This issue is resolved in an upcoming VCF 9.1.x release. The fix introduces a fallback reverse DNS resolution mechanism during Operations discovery. Once Fleet and SDDC LCM are upgraded, the system will auto-remediate the IP to FQDN mismatch during upgrade/import.

To prepare for the upgrade or to request a manual workaround:

  1. Verify that the reverse DNS (PTR) resolves correctly for the VCF Operations node's IP address (e.g., IP AddressFQDN).

  2. If immediate unblocking of the installer is required before the patch is available, please contact Broadcom Technical Support and reference this Knowledge Base 448972 to apply a manual database remediation.

Additional Information

Post-upgrade or post-import, in VCF Components page, the IP address showing up in place of the FQDN for VCF Operations is expected behavior. It should not cause any upgrade issues post VCF 9.1.x, where the fix will be available.

Admin UI displays IP address instead of FQDN in brownfield deployments of VCF Operations 9.1.x

To receive updates on this issue or related issues, reference KB Subscribe to a Broadcom knowledge article by article or product