The HCX Manager UI displays a failure during the "On-demand uplink metrics test" within the Transport Analytics wizard, even when the Service Mesh status and Data-Plane tunnels are reported as Up/Healthy.
Symptoms:
On-demand uplink metrics test failed" appears in the HCX Manager UI.applianceSummary.txt) health status for the appliance show:"reasons": [
"System state is critical",
"Config engine is in systemdBad state.",
"Partition root has problem to create new files. Err: open /fscheck####: read-only file system"
]
This issue occurs when an HCX Interconnect (IX) or Network Extension (NE) appliance enters a read-only file system state. The HCX Manager UplinkUnderlayMetricOnDemandCollectorJob fails because the appliance cannot write diagnostic result files to the local disk.
To restore functionality, the affected appliance must be redeployed to reset the file system state.
Note: If there are active extended networks, a maintenance window must be scheduled to perform the redeploy as it will cause a brief disruption to traffic on those networks.
Infrastructure > Service Mesh.View Appliances.ystemdBad or read-only file system state.Redeploy.Force Redeploy.On-demand uplink metrics test.For ongoing status updates regarding this behavior, subscribe to this article. Reference: Subscribe to a Broadcom knowledge article by article or product