Breaking Enhanced Linked Mode between vCenters fails with error 'Leave federation cleanup failed'
search cancel

Breaking Enhanced Linked Mode between vCenters fails with error 'Leave federation cleanup failed'

book

Article ID: 448302

calendar_today

Updated On:

Products

VMware Cloud Foundation

Issue/Introduction

  • Breaking Enhanced Linked Mode between vCenters using command : 'cmsso-util unregister --node-pnid <vCenter_FQDN> --username [email protected]' fails with the following error:

    Stdout = vdcleavefd offline for server <vCenter_FQDN>
    Leave federation cleanup failed. Error[1] - Operations error
    Stderr = password:
    ERROR unregistering computer account

  • The target vCenter node being unregistered on the source vCenter is in Powered ON state.

Environment

VMware vCenter Server 8.x

Cause

  • When the target vCenter Server node being unregistered remains Powered On, its VMware Directory Service (vmdir) actively runs and participates in the Single Sign-On (SSO) federation.
  • As a result, the cleanup script cannot forcefully purge the active database records, triggering an LDAP/RPC "Operations error" as a built-in safeguard to prevent directory corruption and a split-brain topology.

Resolution

Note: Take offline snapshots of all the vCenters in Enhanced Linked mode. Refer "Snapshot Best practices for vCenter Server Virtual Machines" and "VMware vCenter in Enhanced Linked Mode pre-changes snapshot (online or offline) best practice" for more information.

  1. Ensure the target vCenter being unregistered is in Powered OFF state.
  2. Follow the steps provided in Splitting Enhanced Linked Mode (ELM) to break the ELM between the vCenters.