HCX is unable to reach HCX-WAN-IX-EDGE on the ports 8123. Please ensure firewall is not blocking the ports or routing is correctly configured./common/logs/app.log displays the following exception: com.vmware.vchs.hybridity.adapters.unified.hbr.server.fault.HbrConnectionException: Error connecting to HBR server <REDACTED_IP>:8123. Reason: HttpHostConnectExceptionError connecting to HBR server <REDACTED_IP>:8123. Reason: HttpHostConnectException
The issue happens due to a RACE condition where If hbrsrv happens to start (at boot, or whenever the hbrsrv service is (re)started) before hostd has applied that tagging / before the tagged vmknic has acquired its IP, hbrsrv will load whatever hbrsrv-nic.xml contains at that instant.
This issue is resolved in VCF 9.1.1, available at Broadcom downloads.
If you are having difficulty finding and downloading software, review the Download Broadcom products and software KB.
Verification Steps
Before applying the workaround, confirm the service status at the CLI of the HCX IX appliance
go <IX-Appliance-ID-number>sship netns exec plr_sr bash
netstat -plnt | grep -i hbrsrvnetstat -an | grep 8123Furthermore, reviewing the configuration file in IX appliance located in or /etc/vmware/hbrsrv-nic.xml shows the /opt/vmware/etc/hbr/hbrsrv-nic.xmlipForHMSbound to an incorrect IP rather than the expected Management IP of the IX appliance..
root@<Obfuscated>-IXE-R1 :~ # cat /opt/vmware/etc/hbr/hbrsrv-nic.xml
<config>
<ipForHMS><Incorrect-IP></ipForHMS>
<ipForNFC/>
<ipForFilter>127.0.0.1</ipForFilter>
</config>Workaround Procedure
Apply the following steps to both the source and destination Service Meshes:
list to view and identify the affected Inter-Connect Appliance (IX).go <IX-ID> to select the affected IX appliance.ssh.systemctl stop hbrsrvsystemctl start hbrsrvAfter executing the above steps, ensure that on the IX appliance, the service hbrsrv-bin is listening on to the port 8123 and the file has the entry of the Management IP of the IX appliance for ipForHMS parameter./opt/vmware/etc/hbr/hbrsrv-nic.xml or /etc/hbr/hbrsrv-nic.xml